What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

If you answer your own question, a message box appears which you have to press OK to in order to answer the question. However, if you are using Chrome, the user may tell the browser to stop sending those messages.

Google Chrome dialog screenshot

If the users have chosen to prevent that dialog box, the next time they click on "Answer your own question" nothing happens.

I guess it's a little bit like trying to handle JavaScript or cookies being turned off, but I thought it would be useful to let you know.

Oh BTW: I first found this issue on my own website. What I've done is used a jQuery custom alert box (I think it looks nicer anyway) which obviously doesn't have this tick in! Then the only time I use the browser is alerting the user when they might want to leave the page.

Oh and also: I've just noticed that the button behaves the same when JS is turned off.

share|improve this question
    
I think the problem is what the browser returns to the JavaScript code showing the dialog box; it seems as if the code is getting back the code for the "Cancel" button, which would cause the effect you are noticing. –  kiamlaluno Aug 5 '11 at 15:01
1  
Is this a MacOS thing? I don't see the check box in Windows –  ChrisF Aug 5 '11 at 16:51
    
@ChrisF Its in windows too. If the page has multiple alert or confirm boxes, the second and subsequent messages will have the checkbox. –  Kyle Trauberman Aug 5 '11 at 18:02
    
@ChrisF Yea, you have to click it a couple times before the tick shows. –  ing0 Aug 5 '11 at 18:03
    
@kiamlaluno You're right, it's defaulting on cancel. –  ing0 Aug 5 '11 at 18:18
    
I'm sure this has also happened in Firefox to me before but I couldn't get it to repeat so I'm not sure there. –  ing0 Aug 5 '11 at 18:22

2 Answers 2

I doubt there's a way for SO to disable this. Chrome is doing this to protect you from sites that spam endless dialog boxes, and the protection would be worthless if the site could just disable it.

The only viable solution I see to this would be to change it to use a custom popup (like the ones for flagging) rather than a dialog box.

share|improve this answer

So, let me get this straight...

You check the box to prevent the page from creating additional dialogs, and then file a bug report here complaining that the page is not creating any additional dialogs?

What's wrong with this picture?

And what do you want us to fix, again? We haven't figured out a way to fix the users...

share|improve this answer
    
No. I checked the box to prevent the page from creating additional dialogs, and then I filed it here to let the developers know about the results. At the least, the Answer Question button could proceed to answer the question instead of trying to show the warning. –  ing0 Aug 7 '11 at 1:39
    
Oh btw, I don't want you to fix anything, like I said I was just letting the developers know about this. –  ing0 Aug 7 '11 at 1:40
    
@ing0: The results seem exactly in line with what I'd expect. I'm obviously missing where you think the "bug" is. You asked for a certain behavior, and you were given exactly that behavior. To do anything else would be a bug. –  Cody Gray Aug 7 '11 at 3:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .