What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 129 Stack Exchange communities.

At odds, when I try to edit a question's tags, I get this error when clicking 'Save Tag Edits':

Uncaught TypeError: Cannot call method 'find' of undefined

The corresponding code appears to be inside inline-tag-editing.js:

var disableButtons = function() {
    jTagList.find('input[type="button"]').attr('disabled', 'true');
};

This is happening on Chrome 13.

Could this possibly be solved? I understand it might be difficult with so little information but again I'm not sure how to reproduce since it does not always happen.

Edit: I see why it happened. When I edit a post (full edit including title/body), then save it, and then edit only the tags (with the inline tag editor), I get this error.

share|improve this question
    
Have you cleared your cache? –  random Aug 24 '11 at 20:50
    
@random: I just cleared it. I will edit when it happens again or if I don't experience it anymore. –  pimvdb Aug 24 '11 at 20:52
    
@random: It was not my cache. Please see my edit. –  pimvdb Aug 24 '11 at 20:56
    
Maybe it's related to this recent bug? meta.stackexchange.com/questions/102485/… –  Shadow Wizard Aug 24 '11 at 21:02
    
@Shadow Wizard: It might be, although that one is fixed. –  pimvdb Aug 24 '11 at 21:03
    
ah yes, I have reproed this before. Has to do with doing an inline full edit, then a tag edit. –  Jeff Atwood Aug 24 '11 at 22:51

1 Answer 1

up vote 2 down vote accepted

This was a timing issue causing a JavaScript object to be overwritten with another one too early (because a JS file was included several times) in certain cases. We've switched to loading the inline tag editing code via our deferred JavaScript loader; among other advantages, this causes the file to only be loaded once, fixing this problem.

share|improve this answer
2  
not deployed to SO yet, but will be shortly –  balpha Aug 25 '11 at 7:41
    
I can confirm this is working now. Thanks! –  pimvdb Aug 29 '11 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .