What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

Following comments to this question, the issue described below is probably a recent bug that might affect the badge count of all users on all sites. Thus, much of my original question is probably not related to the root cause of this particular bug. Or maybe it is, you never know.

Today, to my surprise, I was awarded the Taxonomist badge on Stack Overflow. That was unexpected because I don't usually create tags there (but when I do, they're renamed in the next fifteen minutes).

To my even greater surprise, that badge did not reflect in my silver badge count, which remains stuck to 22 instead of the expected 23 (and I counted that twice... thrice... four times now).

Initial investigations on meta led me to Wrong Badge Count, and at first glance it explained the issue because I didn't believe the badge to actually be legit. However, further digging revealed that award is actually a side effect of one of my first edits on SO (I wasn't even realizing I was creating a new tag back then) and is perfectly legitimate after all.

That led me to Myself's answer to Rebecca's question, which acknowledges that Webmaster's Enthusiast badge was not recomputing the badge tally when awarded but, unfortunately, does not explain why.

Are there badges that do behave this way, and if so, which ones? Is there a legitimate reason for them to do so, or can they be fixed?

share|improve this question
    
I've noticed this on my Meta Pro Webmasters account The header says 6 badges, but the main body of the page says 8. The 2 badges are Supporter and Analytical. It was updating yesterday. –  ChrisF Aug 26 '11 at 20:25
    
It looks like there is some bug with your badge count not updating ... this only started today. –  Paŭlo Ebermann Aug 26 '11 at 20:28
    
Interesting. According to my profile here on meta, I have 3 silver badges and 15 bronze, for a total of 18. The header, however, only shows 2 silver and 15 bronze. –  hammar Aug 26 '11 at 20:29
1  
@hammar - it seems to be affecting any badge awarded today. You get the badge and the main body of your profile updates, but the header doesn't. –  ChrisF Aug 26 '11 at 20:31
    
@Paŭlo, ChrisF (damn that only one @ rule), so it's a recent bug that affects all badges on every site? –  Frédéric Hamidi Aug 26 '11 at 20:36
1  
Looks like this, but your post was the first I've seen here to report this. Thanks! –  Paŭlo Ebermann Aug 26 '11 at 20:42
2  
Frédéric - It certainly looks that way. I was going through sites getting Analytical (well you have to) and the totals were updating yesterday but not today. (cc. @Paŭlo) I was thinking of raising the issue myself (once I'd confirmed I wasn't seeing things). –  ChrisF Aug 26 '11 at 20:42

1 Answer 1

up vote 23 down vote accepted

This was my fault, a backwards null check was doing the opposite of what's intended...it will be fixed in the next build and counts will sync themselves tonight.

For those curious: what we saw is sometimes a user got deleted mid-grant, so in a tight loop of "update counts on users who got badges" we'd have granted a badge, but then be unable to fetch the user throwing a null ref. Of course that check works better as a if (user == null) -> skip, rather than the opposite.

Update: deployed, badge counts will sync tonight (a sync actually runs every night, just in case)

share|improve this answer
11  
Love it when developers admit silly mistakes in public +1. –  BalusC Aug 26 '11 at 22:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .