What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I sure hope this hasn't been reported before, but here it goes:

When I do a search on StackOverflow (e.g.: sql multiple tables), I get a page full of responses (yeah!) and then they all disappear! I scroll to the bottom and there is a second page link. I click on that and the same thing happens. The screen is painted with all the responses and then they disappear.

I've tried this with Firefox 3.5.1 and with Seamonkey 1.1.17 and IE 6 with the same response.

Is this a known problem or am I doing something wrong?

Thanks for your help.


Further info: I am running on a Windows XP Pro box with 2 GB of RAM. It doesn't happen if I disable Javascript, but then I lose other features of StackOverflow (like commenting). I have not tried it when logged off because I am now reasonably certain that it is not a problem on my end; three different browsers demonstrate it.

Also, I've been using SO for quite a while and this has never happened before, so I suspect something new.

share|improve this question
    
Hmm... works fine with FF 3.0.12, FF 3.5.1, and Epiphany 2.26.1 on Ubuntu 9.04 –  Zifre Jul 28 '09 at 18:38
    
Tell us more about your system/setup. –  Jonathan Sampson Jul 28 '09 at 18:44
    
I edited my original post to include more information, but since it doesn't happen on Ubuntu 9.04 (see Zifre, above) it may be a Windows-specific Javascript problem. Or not. –  Harold Bamford Jul 28 '09 at 18:53

2 Answers 2

up vote 3 down vote accepted

It's a simple issue of tag filtering. Filters are applied on the client side with Javascript. As soon as the page loads, all your ignored tags are filtered out, hence they disappear. Whatever you're searching for always contains at least one tag which you've chosen to ignore.

Steps to reproduce.
1. Add a tag such as C# to your ignore list
2. In search, type in [c#] , and hit enter

Notice the resulting search will undergo the behavior you have described.

share|improve this answer
    
If this is the case, results of a tag search shouldn't be filtered by ignored tags... –  ajm Jul 28 '09 at 18:54
    
So how would I ask a question about using SQL to query multiple tables if having the keyword "SQL" disables the display? I don't get this if I ask about: Perl multiple tables –  Harold Bamford Jul 28 '09 at 18:57
    
If a question contains any tag that you filter it will be removed. This is unavoidable. I agree that filters should not apply to search pages. Remove the filters temporarily, or log out and complete your search. –  Ian Elliott Jul 28 '09 at 18:59
    
That does it! Until today, I was uninterested in seeing anything to do with SQL and now, for once, I am interested. Now I need to figure out how to remove those tags from my ignore list. –  Harold Bamford Jul 28 '09 at 19:00
    
This happened to me while helping out a friend... I had [PHP] ignored and then when searching for "PHP XML" (on his behalf) I experienced the 'flickering' show/hide of results. Didn't take too long to figure it out - but IMO if Ignored Tags hides 100% of the page content it would be nice to get a warning "XX results hidden due to Ignore Tag settings"... the flicker-blank behaviour is a little 'weird' –  CraigD Aug 30 '09 at 22:33

Do you have greasemonkey turned on, or some other scripting platform that may be ruining the dom? Try this in IE, Safari, Opera or Chrome.

Perhaps disable Javascript. See if it still happens.

Does it still happen if you're logged out?

share|improve this answer
    
No greasemonkey or anything similar. I just tried it with IE 6 and it does the same, except slower. As soon as the entire page is painted, it clears out the results. –  Harold Bamford Jul 28 '09 at 18:32
    
It sounds like a scripting issue - try disabling javascript. –  Jonathan Sampson Jul 28 '09 at 18:33
    
That fixes it, however at the top of the page there is now a large red bar with the message "Stack Overflow works best with JavaScript enabled" showing. And I believe it, except for this case. –  Harold Bamford Jul 28 '09 at 18:39
    
And adding comments here also fails to work with Javascript disabled! –  Harold Bamford Jul 28 '09 at 18:40
    
Yes. Well at least we know it's Javascript :) –  Jonathan Sampson Jul 28 '09 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .