What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I tried referring to 2 members by placing the '@' symbol before their names in a comment. I removed one of the '@' symbols and was able to post the comment.

I then clicked on 'Edit Comment' and tried adding the '@' symbol, but this time around I got an error message that said "You may only edit a comment every 5 seconds".

I think this error message shouldn't have been shown and is incorrect since this was my first edit of the comment.

Edit: This error appears even if the comment is new. To summarize: if I post a comment referring to two members, I get the error as shown here.

I'm running Chrome 14.0.xxx.xxx on Ubuntu 11.04.

share|improve this question
1  
Your bug report is kind of confusing. Are you reporting that the error message is incorrect ("cannot post within 5 seconds" instead of "cannot @-address more than one person") when you try to edit the second @ back in? –  Anna Lear Sep 25 '11 at 3:31
    
@AnnaLear: That is exactly what I'm saying. I didn't know that there was a restriction placed on the number of people you could tag in a comment. That's the reason I don't mention that in the problem description. I knew of that restriction only from the linked purportedly duplicate bug report. Thank you for paying attention to the question. Really appreciate it. –  user183037 Sep 25 '11 at 3:36
    
@user183037 You should have been notified of the restriction when trying to post a comment with more than one @ in it. –  Anna Lear Sep 25 '11 at 3:42
    
@AnnaLear: I was not. –  user183037 Sep 25 '11 at 3:46
    
I've closed the older question as a duplicate of this one, and modified this one to match the edits @AnnaLear made to the other. Better? –  Dori Sep 25 '11 at 4:24
    
Dori: I really don't mind which one is closed/kept opened as long as the issue is addressed. But there were several comments exchanged with @waiwai933 that aren't present in either thread now. Though it specifically didn't have much to do with the bug report at hand, it definitely reflected the general attitude of trigger-happy duplicate markers. If you removed them to keep the discussion on topic, I can live with that. –  user183037 Sep 25 '11 at 5:25
    
@Dori can't you clear the Close flags? It's really confusing.. –  Shadow Wizard Sep 25 '11 at 7:44
    
    
@user183037 - With only one question open, those comments were no longer relevant to the actual issue. I removed them to keep them from being a distraction. –  Dori Sep 25 '11 at 18:00
    
@Shadow - If there's a way for me to do that, I've never found it. –  Dori Sep 25 '11 at 18:01
    
@Lance - We've been through this; it's a different issue entirely. –  Dori Sep 25 '11 at 18:03
    
@Dori, actually I think it's the same issue, just maybe a different variant (5 vs 15 seconds, editing vs posting (though editing is still the cause)). –  Lance Roberts Sep 25 '11 at 18:04
    
@Lance - Then you haven't read the entire page; below, he says he's getting the editing error even when he has not edited anything. –  Dori Sep 25 '11 at 18:09
    
@Dori, His question specifically mentions editing, but it doesn't actually matter, the erroneous error message is the same type as the other question. I don't really care if this question gets closed or stays open, I just didn't agree with the duplicate others were choosing. –  Lance Roberts Sep 25 '11 at 18:13
    
@Lance - As I said, "read the entire page"—particularly, his comment below that says "I wasn't editing it, I was posting it for the first time." –  Dori Sep 25 '11 at 18:18

1 Answer 1

up vote 7 down vote accepted

To expand/clarify what's happening, I did some experimenting and it looks like there are two things going on:

  1. You cannot @-address two people in the same comment. When you try to do so, you will see the following error:

    screenshot

  2. You can only post one comment every 5 seconds. An comment edit appears to count as posting a comment. In that sense, your first question appears to have correctly been closed as a duplicate of this question. It is also about the "you can only post one comment every 5 seconds" error being shown erroneously in a similar scenario.

The time between your first comment and your second comment doesn't matter here. The reason you saw this message is because there was less than 5 seconds between you posting the second comment and editing it. If you wait longer before editing, you should see the "only one additional @user" pop-up if you try to add a second @ into the comment.

It seems, though, that I can edit comments even within the 5-second window if there are no issues with the edit that would normally show an error.

So, it looks like your bug here is that the "only one additional @user can be notified" but "you can only edit a comment every 5 seconds" message is shown instead.

share|improve this answer
    
Although personally I think the fact that the rate limiting comes first is status-bydesign. –  Tim Stone Sep 25 '11 at 4:50
    
"So, it looks like your bug here is that the "only one additional @user can be notified" but "you can only edit a comment every 5 seconds" message is shown instead." - that is exactly what's happening. In fact, in one of the comments to the question above, I addressed the comment to Dori and referred to waiwai in the text. When I hit submit, it gave me the rate limiting error again. Note that it was a comment after a good hour or so from my previous comment. Also, I wasn't editing it, I was posting it for the first time. I took a screenshot this time, I don't know how useful that is though. –  user183037 Sep 25 '11 at 5:28
1  
@user183037 You might as well post the screenshot for good measure. Also, could you indicate your browser and operating system information? –  Tim Stone Sep 25 '11 at 6:13
    
The 5/15 second comment editing bug is referenced here: meta.stackexchange.com/questions/103037/… –  Lance Roberts Sep 25 '11 at 17:58
1  
@TimStone: Here you go: img6.imageshack.us/img6/4814/bugstackoverflow.png (notice the 2 '@' in the comment text). That comment wasn't an edit, it was a new one. Bug report updated to include OS and browser information. –  user183037 Sep 26 '11 at 0:28
    
@user183037 In your screenshot, what's the red icon in the right of the omnibar? Also, when you submit the comment, are you pressing enter in the text field, tabbing to the comment button and pressing enter, or clicking the comment button with your mouse? I have a guess as to what the issue is, although I'm at a loss to explain why it would be happening. –  Tim Stone Sep 26 '11 at 0:45
    
@TimStone: That's Adblock Plus. I don't think it's the reason because I'm getting error message 1 instead of error message 2. If I didn't get either, I would have faulted it :) I usually simply hit enter to post the comment. –  user183037 Sep 26 '11 at 1:06
1  
@user183037 Are you able to reproduce this every time you submit a new comment containing two @names? If so, could you open the Chrome Developer Tools before you do and grab a screenshot of the requests made during the submit? –  Tim Stone Sep 26 '11 at 4:14
    
    
@user183037 Hm...weird. I'm out of ideas then, since I'm unable to reproduce this myself. Hopefully a dev can shed some light on what's going on. –  Tim Stone Sep 26 '11 at 6:10
    
@Tim, what I can't understand at all: on Meta.SO it should say 15 seconds, not 5. –  Hendrik Vogt Sep 26 '11 at 6:43
    
@HendrikVogt Oddly, it seems to be alternating between 5 and 15 for me (or I'm hallucinating). –  Tim Stone Sep 26 '11 at 7:01
    
@HendrikVogt: It's always showed me 5 seconds. –  user183037 Sep 26 '11 at 7:07
    
@TimStone: hehe, that's okay, thanks for trying :) –  user183037 Sep 26 '11 at 7:08
    
@Tim: Here on Meta it's 15 seconds for comment submissions, 5 seconds for edits. –  Hendrik Vogt Sep 26 '11 at 7:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .