What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 122 Stack Exchange communities.

Links to audio files hosted on SoundCloud automagically turn into a player. This is great! However, I tried to upvote the implementation post, which is currently beneath earlier, higher-voted posts. I wasn't logged in, so it sent the "Please log in" popup. This appeared below the player:

enter image description here

The player should go behind almost anything that appears on the page, including this message. Unfortunately, this in't how Flash wants to work.

You currently add the player with this embed:

<object height="81" width="100%">
            <param name="movie" value="http://player.soundcloud.com/player.swf?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F18311992&amp;auto_play=false">
            <param name="allowscriptaccess" value="always">
            <embed src="http://player.soundcloud.com/player.swf?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F18311992&amp;auto_play=false" allowscriptaccess="always" height="81" type="application/x-shockwave-flash" width="100%">     
</object>

I realize that you probably copied this code from http://developers.soundcloud.com/docs/widget#quick-start, (By the way - thank you for disabling auto-play), but this leaves the Flash in its default

<param name="wmode" value="let_my_ads_bleed_through_everything">

state. This can be fixed from your side, SO can help you with this.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Since you already did all the work, there's not much left to say :)

From the next build on, the wmode parameter is set to opaque. Note that this happens at post render time, so this isn't fixed retroactively, but only on edit (I consider that okay, since it's not a really major issue).

Thanks!

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .