Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

Trying to post a comment to a recently-closed question on Stack Overflow.

Instead, when i hit the "Add Comment" button, SO loads this url:

...and no comment is posted. Note that the comment text appears in the querystring...

share|improve this question
Weird. It doesn't even validate that the comment is long enough or anything. – Hilarious Comedy Pesto Jul 29 '09 at 19:50
up vote 2 down vote accepted

Why would you want to comment on closed posts? :)

Last night's push removed the awesome jQuery Validation plugin. We love it, but don't need all its functionality on this site.

We still want some client validation, so there's some very minimalistic code that's added when the question/answer editor is available on the page - closed posts don't have the editor!

Fixing (and I'm sorry!); will be in tonight's code push.

share|improve this answer

That just happened to me while trying to comment on I commented on a non-closed question about 15 minutes ago, so I see no obvious reason for the failure.

Edit: I tried several other questions, some closed, some not. Commenting worked on every open question and failed on every closed question. This is definitely a bug.

share|improve this answer

Just noticed this behavior right now.

Is the "comment library" already fixed? ;)

share|improve this answer

I noticed this too, except that the question I tried to comment on, someone else managed to comment after it was closed (after my attempt had failed). I assumed that commenting on closed questions was now something only higher-rep people could do. I guess I was wrong.

I can't find the question I first experienced it on, probably has been deleted. It was that "Are you the owner of <some name vaguely related to stack or overflow>?" question.

share|improve this answer

Confirmed again... definitely a glitch in the matrix...

share|improve this answer

I found that this happened when I tried to include a second jQuery library into the page with Greasemonkey. (Then I realized I could use the current one).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .