What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I haven't received a badge since July 19th. Since then I have answered at least three questions that should have earned me a nice answer badge, and I haven't been awarded any of them.

I was wondering if anyone was noticing anything similar.

share|improve this question
    
I got two "nice answer" badges on Monday, so I don't think it's a bug. –  mmyers Jul 29 '09 at 20:16

2 Answers 2

up vote 6 down vote accepted

Occasionally, you will not receive a badge because you "lost" a badge, only the system does not take them away. Simply, the next time you would have received that badge, you don't. I wouldn't be surprised if a number of people are experiencing this on SO due to the number of questions migrated to both meta and SU since their launching.

share|improve this answer
    
Would the migrating of questions affect this? –  jjnguy Jul 29 '09 at 20:11
    
However, I know I never earned an 'Enlightened' badge on any of the FAQ questions of mine that got migrated. –  jjnguy Jul 29 '09 at 20:13
    
I can't find a post confirming this, but yes, I'm fairly certain, you "lose" the badge on the site a question is migrated from. However, the loss is not recognized until you would be receiving another of the same badge, at which point you don't receive anything. I'm not sure why it's implemented this way, but I believe that is the documented behavior. –  Timothy Carter Jul 29 '09 at 20:15
1  
You should earn the badge on the new site too - I've seen several "Good Answer" badge notifications turn up on the home page soon after a migrated question appears on the site. –  ChrisF Jul 29 '09 at 20:19
    
In fact there are several there now & I see that this question meta.stackexchange.com/questions/10811/… has just been migrated. –  ChrisF Jul 29 '09 at 20:20
    
@ChrisF, yes you should receive the badge on the site the question was migrated to, so long as the accounts are associated. –  Timothy Carter Jul 29 '09 at 20:20
    
I shouldn't have lost the badges there. They have definitely not been transferred over here. –  jjnguy Jul 29 '09 at 20:46
    
@jinguy - have the questions been migrated to SuperUser? –  ChrisF Jul 29 '09 at 21:20
    
Well, assuming getting badges here should correlate with losing badges there, I shouldn't. Because I have none of the badges here. –  jjnguy Jul 29 '09 at 21:21
    
@ChrisF meta –  jjnguy Jul 29 '09 at 21:21
    
@jjnguy, something has happened to a few of the answer you've provided. In your SO profile right now, you have an equal number of 10+ upvoted answers and "nice answer" badges, however, you have only 4 questions currently at or over 25+ upvotes and 6 "good answer" badges. I don't know what would have happened, but it seems the questions you provided answers for either got deleted or moved. –  Timothy Carter Jul 29 '09 at 21:27
    
Must be the deleted answers from migrating...Bummer. Gone and never coming back. Makes me sad. –  jjnguy Jul 29 '09 at 21:29
    
Prolly gonna accept. I'll wait until closer to UTC midnight. –  jjnguy Jul 29 '09 at 21:29

IMO this is very likely due to meta-questions being migrated here, as a lot of the meta-questions were quite popular and probably had badges attached.

You never lose badges -- you just don't get new ones until the count is >= what you're supposed to have.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .