What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

Following on from this answer about spam hunting I've been using super ninja searching to try and spot patterns with spammy URLs in answers.

I spotted something suspicious today, a string of accounts posting one and only one answer all linking to the same site so I flagged one of the posts and requested that mods would use some of the tools available to them to check that the accounts aren't all the same individual. (One of the answers even says "I just replied to a similar question with this link" but the only other answer linking to that page is from another one of these users)

In the text for the "other" flagging reason it suggests providing URLs, it seemed sensible to include the search URL so I copied and pasted it.

It seems though that the * in the URL broke the link handling in flags as when I view the flagging summary I see:

truncated URL in flagging summary

The link on the page points to everything I hoped except for the *" at the end of the search string. It seems this is a bug:

The URL isn't correctly being handled in the free-form text (A regex perhaps has * as an invalid character?)

It's more annoying than this case because if it were a post/comment I could edit it to correct the URL however in this case there's nothing that can be done.

Update

I spotted another similar pattern linking to a different blog in a different tag so I figured I'd give the link another go using the markdown that works in comments and the result was no better - the markdown didn't seem to show in the flagging summary screen and the URL still got truncated:

still broken, even with markdown

It seems then that there is no way to write a link with a * in a flag message that doesn't get broken. (There wasn't a space in what I wrote in the box)

share|improve this question
    
Possibly related? meta.stackexchange.com/questions/20936/… –  Pops Oct 5 '11 at 21:35
    
@PopularDemand - I tried using the [link](http://link.com) syntax in the flag box for another similarly suspicious case and that didn't work too. I think there's no way of properly including a URL with a * in the flagging box currently. –  Flexo Oct 6 '11 at 14:12
    
Since I've seen this twice in two days I'm wondering how common it is for avoiding spam detection and how effective it is at escaping undetected too. I guess that's another question. –  Flexo Oct 6 '11 at 14:18

2 Answers 2

up vote 3 down vote accepted

Anywhere you would use * in your URLs, use %2A instead.

share|improve this answer

I'm going to call this by-design for now. It doesn't look like we outright mangle URLs anymore:

enter image description here

And as Dori pointed out, there's a workaround.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .