What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I tried to log on for advice on increasing my computer's security.
Using Firebug, I had discovered a one pixel "image" which caused my Mac to be studied by 2o7.net. I've since learned a bit more about tiny iframes and gifs doing this.

I checked with Firefox. The very first suggestion the gave was: "Don't accept 3rd party cookies." So, of course I turned off their acceptance.

Lo and behold, Stack Exchange requires enabling 3rd party cookies or else I can't log into my account?

It seems ironic.

Even if the reason is benign, wouldn't it be smart on such as site as this to include a word or two about why you need this 3rd-party cookie?

share|improve this question
3  
I have third-party cookies set to "do not accept", and I've never had issues logging into SE. –  Nightfirecat Oct 12 '11 at 20:54
    
Only chat requires third-party cookies, to my knowledge. –  Matthew Read Oct 12 '11 at 21:03

2 Answers 2

You don't need third party cookies to log in.

What you do need for global login (i.e. automatic login to other SE sites after you've logged in to one of them) is localStorage access through a cross-domain IFRAME. This is usually the same setting in browsers (for good reasons, since except for the JavaScript requirement, it has almost identical implications).

This feature is optional though. If you disallow it, you have to log in to each site seperately. Only chat.SE actually requires it, but even there we've added a "broken browser" workaround.

If you want to use this feature, you have to whitelist access to http://stackauth.com from the site; that's our centralized auth domain.

Analytics also want third-party cookies, but that's of course even more optional.

share|improve this answer
    
thanks for the useful explanation, @balpha. Can you explain what "whitelist stackauth.com" means: i.e., how does one go about whitelisting stackauth.com? I am also experiencing the same issue. –  D.W. Nov 16 '11 at 2:58
    
I don't know; depends on the tool you're using, I guess. You must know where you disabled third-party cookies? –  balpha Nov 16 '11 at 5:29
    
I disabled third-party cookies in Firefox. I do not see an obvious UI element to whitelist a single site. Others have said that they don't see any way to whitelist sites in Chrome, either. Your phrasing made me assume that you believed some browsers provide a way to whitelist third-party cookies from individual sites; if so, I'd be interested to learn about how to do it for the ones where you know the answer. Or, if I read too much into your phrasing, never mind. –  D.W. Nov 16 '11 at 17:21
    
P.S. I'm not interested in enabling third-party cookies for every site on the Internet (which is apparently my only choice) just to make Stack Exchange work. So if you or anyone knows of any tool/extension/proxy/etc. that can be used to allow third-party cookies for Stack Exchange, but block all others, I'd be interested to hear. –  D.W. Nov 16 '11 at 17:23
    
It may not be possible; I assume there are some extensions that can block or enable them selectively. As I said, everything should work without; you're just missing out on a few conveniences. –  balpha Nov 16 '11 at 19:00
    
thank you @balpha! This is highly preferable to others' suggestions to blanket "allow third-party", to which I am highly averse. –  click_whir May 17 '13 at 4:40
    
For Chrome, open your setting url chrome://settings/ and click "Show advanced setting" so that Privacy appears, and then click "Content Setting" under Privacy. If "Block third party cookies" is checked, then click "Manage exception" and add stackauth.com. It works for me! If "block third party cookies" is unchecked, then you've some extension doing it, so check it's config page. –  Jeff Burdges Jan 18 at 10:23

With thanks to balpha on another question, where I had the same issue - You can login with StackExchange's OpenId provider, but not directly.

When logging in, visit "more login options", and type "openid.stackexchange.com"

This will take you to a functional login box that does not require third-party cookies.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .