Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I'm not sure whether this is a bug or whether it is by design.

When you search for something that you have flagged not to see, the questions disappear appear from the results page. I assume this is because they have a tag that I have hidden.

Example, I have MySQL hidden from the main questions and Sql-Server as a favourite tag. Earlier, I searched for a post that had Sql-Server and MySQL in the tags, and the questions were hidden.

In my opinion, if I have searched for something that is in my "hidden" list, the results should appear.

Simple re-pro, search for two tags in the same seach, one in your favourite list the other in your hidden list and see what happens.

Note: Thanks to the first comment, I might have made my self unclear. You need to add a search term in after the tags. Eg: [mysql] [sql-server] connection where mysql is ignored, sql-server is a favourite.

Like I said, this is probably by design, but it could be a bug; it's hard to tell.

share|improve this question
    
I can't reproduce this. I tried two different tag combinations, and in both cases, as intended when explicityly searching for a tag that's in the ignore list, the questions did show up. – balpha Nov 17 '11 at 9:15
    
@balpha, did you just search for the tags? Try adding something else eg: stackoverflow.com/… – Stuart Blackler Nov 17 '11 at 10:12
    
@balpha: I can reproduce it (on SU). Make sure you've checked to hide ignored tags. – Time Traveling Bobby Nov 17 '11 at 10:18
    
For me it appeared with half transparency so I can't reproduce. Chrome here, maybe it's browser issue? – Shadow Wizard Nov 17 '11 at 10:20
    
@balpha: I take everything back! This is reproducable if you place a wildcard in the ignored tag. – Time Traveling Bobby Nov 17 '11 at 10:22
    
@ShadowWizard, Chrome here too. Not tried in other browsers... – Stuart Blackler Nov 17 '11 at 11:45
up vote 6 down vote accepted
+50

No, that wasn't by design; the search result page just didn't implement the "explicit search for tag [x], so ignore the tag preferences" logic. This is fixed in the next build.

And while I was at it: Asylum noted in the comments that the behavior isn't quite as expected when you have wildcards in your tag preferences. This is now handled, namely as follows:

Assume you're ignoring [jquery*] (of course nobody would do that, but just imagine it), and you have searched for [jquery-plugin] basic arithmetic. So far, you wouldn't have seen any results, because every question on the search result page matches your wildcard ignore. Now (next build), your [jquery*] ignorance will be ignored (ignore the double ignoring), because it matches one of the searched-for tags.

So results from that page will then only be hidden if they also have some other tag that you're ignoring.

Oh, and also: This had nothing whatsoever to do with the tag engine of doom.

I can haz bounty?

share|improve this answer
2  
Thanks for the explanation and fix :) You can have the bounty in 20 hours :) – Stuart Blackler Nov 17 '11 at 12:33
    
Thanks for that interesting read (your answer and the blog post about the tag engine). Very interesting stuff. – Time Traveling Bobby Nov 17 '11 at 13:11
    
bounty awarded :) – Stuart Blackler Nov 18 '11 at 9:26

Well, this is what I see when searching with one of the tags in my ignore list:

screenshot

You say you get no results at all?

share|improve this answer
    
The behaviour here is different depending on your user-prefs – Marc Gravell Nov 17 '11 at 12:08
    
@MarcGravell EDIT: you mean the "hide ignored tag" checkbox in the prefs tab of profile page? – Shadow Wizard Nov 17 '11 at 12:10
    
yes, that exactly – Marc Gravell Nov 17 '11 at 12:17
    
@MarcGravell, Ahh, I do have "hide ignored tags" checked. Shouldn't you still see the questions if you explicitly search for them? – Stuart Blackler Nov 17 '11 at 12:18
    
So this is obviously by design.. :) – Shadow Wizard Nov 17 '11 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .