What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I wrote a question (of normal length), and when I click submit (after filling question body, title, and tags), it just waits there and times out. I tried several times, even after deleting cookies, but it didn't help.
I've asked about 60 questions, so far, and I'm not new to it. This happened to me again a few weeks ago too: I wasn't able to submit a specific question. This is the body of the question I'm trying to submit, if it helps:

I'm trying to integrate XNA into a WPF window, using the WindowsFormsHost control in the WPF window. I've got a very strange problem that whenever XNA is running, my keyboard input into my WPF window controls don't work. More weirdly, this is happening not for all keys. It happens for all the letters and numbers, but, for example, backspace or delete key work. I first thought this was due to XNA hooking up to the keyboard input and handling all the key presses, and the events weren't being routed to my WPF window. But weirdly, they DO get handled by the OnKeyDown. I've created a custom TextBox class that derives from normal TextBox, overrided the OnKeyDown, put a breakpoint in, and it worked. The debugger stepped on the breakpoint. So I was wrong: XNA wasn't blocking the key events from reaching the WPF window (or its controls), my TextBox IS getting the correct keyboard event, but it just doesn't work. I press 'A' on my keyboard, OnKeyDown gets called, but it doesn't append 'A' into the textbox. The backspace key, on the other hand, works normally. I copy paste some text into the field using mouse right click, and I click on the middle of the text (arrows don't work too), I can delete the text by pressing backspace, but I can't type anything.

What can be the reason? I am not really good with WPF's input handling, but normally, if my TextBox DOES get the OnKeyDown event (with the right argument), it should append the letter that I've pressed. As soon as I end the XNA game, things start behaving correctly. What can be the reason for the controls behaving abnormally?

The previous question was the following one:

Hello,

I'm creating an XNA Game editor which should support Reading writing of Game content (in the XNB format).

I've got the ContentTypeReader working and I (can't test it without writing but anyway) got it working (at least, it SHOULD work), anyway, I can't write any content objects. NO, content won't be created by programmer and added to the content project dynamically, they will be created by game designer who uses my map editor program. To make it more clear, consider this simplest case:

(game designer has content pipeline installed)

I have my game engine project, and there is no content in it, it's empty! I have my map editor ready (and set to work with my game project's content folder)

The game designer will open my object editor and select a JPEG image, add a name and some game-specific properties, and save it into the Content folder of the game. (1)

The game designer will open my map editor, Create a new map, add some objects (that they created in the previous steps) into the map, and save it into the content folder too. (2)

The player, with the game (and of course, XNA redist) installed, opens and plays the map created by the designer.

The problem is clearly in those parts bracketed as (1) and (2): I need to write XNB files, WITHOUT building a project in Visual Studio, just from my application. I don't know where and how to call the Write(Object) method of the content writer.

These are both about XNA, if it makes any sense.

Between these questions, I've asked other questions with no problem. Is there any content in my post that is blocking the question for some reason?

I'm using Firefox 8.0.

share|improve this question
add comment

You must log in to answer this question.

Browse other questions tagged .