What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I can't seem to be able to load page 2 of some chat searches. For example this one: http://chat.stackoverflow.com/search?q=chat+search+sucks&user=46642&room=10. I just get the cat workin on mah problemz.

With some different searches I can load page 2. This one http://chat.stackoverflow.com/search?q=blah&user=46642&room=10 is an example that works.

I confirmed that this is not on my side, because other users seem to get the Oops page too.

I hope the cat that is working on my problem will be able to solve it :)

The cat

share|improve this question
    
Seems to be any page except the first. Sadly it looks like they don't embed the error message in the chat error page –  Michael Mrozek Dec 2 '11 at 5:15
    
I'm investigating, but it seems to work fine for me; is this still happening? –  Marc Gravell Dec 2 '11 at 6:22
    
oh, I see it; that's odd... as "me", it works fine, as an anon user, it times out. Curiouser and curiouser. –  Marc Gravell Dec 2 '11 at 6:23
    
@Marc, Yep, just checked and it still shows the Oops page. I'm logged in, FWIW. –  R. Martinho Fernandes Dec 2 '11 at 6:23
    
indeed; it must be something to do with access checks; looking... –  Marc Gravell Dec 2 '11 at 6:25
    
@Marc I added an example where I can access the second page. Maybe that can help. –  R. Martinho Fernandes Dec 2 '11 at 6:28

1 Answer 1

up vote 4 down vote accepted

For the techie-folk, this was due to parameter-sniffing; the database server had prepared a query plan based on some early typical parameters that was not representative of all the rooms on the site, meaning: for different values, the plan was inappropriate and timed out.

This has been solved by the "dammit will you just work!" clause in SQL server, aka

option (optimize for unknown)

it should now work

share|improve this answer
    
Nice, it works now. Thanks. –  R. Martinho Fernandes Dec 2 '11 at 7:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .