What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Once in compatibility mode, pressing Enter to add comments no longer works. So there is something wonky going on with the scripts (happened on a recent change set that was rolled out?)

share|improve this question
    
Although strangely, it didn't do it for this comment –  Robert Harvey Dec 2 '11 at 19:17
1  
We've had several reports of this -- latest: meta.superuser.com/questions/3758/… -- but so far, we haven't been able to reproduce it. –  balpha Dec 2 '11 at 19:46
1  
That is better wording. +1 –  Robert Harvey Dec 2 '11 at 19:56
    
@balpha: It might be dependent on the nature of the comment. The comment posted just above this one seems to trigger the problem every time. –  Robert Harvey Dec 2 '11 at 19:57
    
Do I unserstand correctly that for you this only started happening recently? –  balpha Dec 2 '11 at 21:07
    
I just started noticing it yesterday or the day before. –  Robert Harvey Dec 2 '11 at 21:08
1  
BLARGH! Happened again. :P –  Robert Harvey Dec 2 '11 at 21:08
    
Just a random thought: what about pressing Enter in the search box? –  Arjan Dec 2 '11 at 21:19
    
@Arjan: That works without problems. –  Robert Harvey Dec 2 '11 at 21:21
    
I would post "Don't use IE" as an answer, but I acknowledge that that's not really a solution (although I wish it were true). –  uɐɯsO uɐɥʇɐN Dec 2 '11 at 23:05
    
Does it depend on the characters in the comment, e.g. for comments ending with a period / full stop? –  Wikis Jan 5 '12 at 14:23
    
IE8, Win XP -- no repro :( –  Shawn Chin Jan 5 '12 at 14:37
2  
It happens on meta too (just happened for this comment). –  Robert Harvey Jan 5 '12 at 18:54
    
I just started having this problem today. Yesterday I did a Windows Update that applied some patches to IE8. –  Mark Ransom Feb 16 '12 at 18:36
1  

3 Answers 3

I can repro this at will and it causes all sorts of issues for me. Once I'm in compat mode, my tags look like crap Why do my favourite tags look screwy only on travel.se? and I can't use arrow keys to scroll after clickg a voting button Has something changed recently that would affect focus for keystrokes? . As you can see by those questions, it's been going on a while for me.

I"m using IE 8 on Win7, 64 bit. Without fail if I press Enter to submit a comment I am put into compat mode if am not already in it. Taking myself out of compat mode by clicking the broken page icon eliminates my screwy tags, keyboard focus problems, etc. I am close to being trained not to press Enter by this bug.

Update: Jan 4th/12 (or possibly a little earlier, I don't comment every day) something changed so that now submitting comments by clicking the button puts me in compat mode. This is so not an improvement. Any chance you can tell what's going on by looking at comment-related code that went live this year?

New Info - commenting on a question (with enter or the button) never puts me in compat mode. Commenting on an answer (again, with enter or the button) always does.

share|improve this answer
    
It's irrelevant that you can reproduce this at will. All that matters is that the devs can reproduce it, because then it can get fixed. How do you reproduce this bug? –  Kevin Vermeer Dec 2 '11 at 20:58
    
I enter a comment on any SE site and press enter to submit it –  Kate Gregory Dec 2 '11 at 20:59
3  
there, i just did it with that comment. 100% of the time I press Enter to submit comments I get into compat mode. meta, so, travel, cooking, english - anywhere I have an account, I have done it on those sites. Beta and graduated. FWIW I often have a LOT of tabs open (32 at the moment). –  Kate Gregory Dec 2 '11 at 21:01
    
and that comment, submitted by clicking, no compat mode. –  Kate Gregory Dec 2 '11 at 21:01
2  
Re your update: There were no comment JS changes, but jQuery has been upgraded, so it's likely related to that. I'm firing up a VM now. –  balpha Jan 5 '12 at 14:18
    
This is a test comment, posted from IE8 / Win7 32 bit, submitted via Enter. –  balpha Jan 5 '12 at 14:28
    
This is a test comment, posted from IE8 / Win7 32 bit, submitted via click. –  balpha Jan 5 '12 at 14:30
    
No reload, no compatibility mode. –  balpha Jan 5 '12 at 14:30
    
testing with enter –  Kate Gregory Jan 5 '12 at 14:31
    
that one got me compat mode and whole page reloaded. Clicking for this one. –  Kate Gregory Jan 5 '12 at 14:31
    
and that one got me compat and reload too. –  Kate Gregory Jan 5 '12 at 14:32
2  
@balpha Have you tried IE8 32-bit with all updates on Windows 7 64-bit (which is what Kate Gregory has, and which is what I have, too)? I can totally reproduce that. I've never used Enter to submit a comment, but since Jan 4(ish) the submit button summons the compatibility mode. –  GSerg Jan 6 '12 at 21:00
1  
@balpha Just moved to a different country. A whole new PC, with Windows 7 SP1 32-bit and IE8 with all updates. Still compatibility mode on comment. –  GSerg Jan 10 '12 at 16:46
1  
@balpha It would appear that IE8 goes into compat mode when you submit a comment and there's aleady an upvoted comment on that same question/answer. If all comments already present on the question/answer are not upvoted, compat mode is not triggered. Presence of upvoted comments on adjancent answers is not relevant. –  GSerg Feb 2 '12 at 0:02
1  
@GSerg is correct. I've been having the same problem, and indeed there's a difference between whether there are upvoted comments or not. –  Alex Mar 6 '12 at 1:51

This is being caused by a "IE8 Specific" page layout error and the effects created can be stopped by doing the following.

To Stop compatibility view from recovering from page layout errors the Solution is simple.(although it took me awhile to figure out were the option was)

Open "Tools" menu then go to "Internet Options". Under the "Advanced setting" tab scroll down to The "Browsing" Section and Uncheck the option "Automatically Recover From page layout errors with Combatibility View"

This will not fix the layout incompatibilty with IE proprietary browsing visualization but there will be no unwanted loss of your individual Menu Items.

share|improve this answer
1  
This seems to do the trick. The page does not look any different after submitting a comment, I am not put into compat mode, and all the annoying aspects of being in compat mode disappear. I do get the page reloaded and focus at the top, but I can live with that. Thanks Argus! –  Kate Gregory Jul 2 '12 at 11:49
    
btw the page reloads and focus is at the top when I comment with Enter, but not when I click Add Comment –  Kate Gregory Jul 2 '12 at 11:49
    
@kate I use the keyboard as well, tab key then space will enter the comment. –  Jeff Atwood Jul 2 '12 at 17:03
    
@KateGregory: no problem. I believe this is happening as a result of a .net framework issue that is a slightly different command path in ie that does not track the position of the scrollbar correctly as this only solves the effects and not the prob itself I will continue to debug. –  Argus Jul 2 '12 at 18:55
    
@balpha the comment is posted here under my work-around –  Argus Jul 4 '12 at 17:20

This bug, which just refuses to die, now has another symptom: no top bar showing my name, rep, badges etc on beta sites in compat mode. I got into compat mode by pressing Enter to comment. There was a comment on the answer already, and it was not upvoted.

On graduated sites the top bar doesn't go away, and I don't remember it ever going away with the sketchy theme on beta sites. I don't know what the fix for this is - whether to stop putting people in compat mode for no reason, or to behave better in compat mode - but I long for it.

share|improve this answer
    
Stop using IE 8. Really. –  U2744 SNOWFLAKE Apr 22 '12 at 21:56
4  
@minitech: A great idea, if you're not working in a corporate-controlled environment. –  Robert Harvey Apr 22 '12 at 23:28
    
@RobertHarvey: I'm not ;) –  U2744 SNOWFLAKE Apr 22 '12 at 23:46
2  
@minitech: Good for you; I am, so I don't have the option. I recently switch to Firefox because, unlike most other programs, you can apparently install (and update) Firefox without requiring administrator rights to your machine. Can't install Chrome, though. Firefox does not suffer from the problem described here. –  Robert Harvey Apr 22 '12 at 23:49
    
@RobertHarvey: Yes, that works on my school computers as well. I suppose you're not allowed portable versions? Ouch. (Anyway, I was addressing Kate Gregory, who might not be. (Who knows? Personal choice can be an odd thing sometimes! (Also, nested parentheses are great.))) –  U2744 SNOWFLAKE Apr 22 '12 at 23:54
3  
@minitech I'm in a 6 month transition between machines. The new machine is IE10. In the meantime this one is staying as-is. –  Kate Gregory Apr 22 '12 at 23:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .