What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

I have a Stack Overflow account with a work email address, an Ask Different account and Photography account with a personal email.

When I logged on today, I used an email address to login to Stack Overflow while in Ask Different. The system then saw I had 2 accounts and asked to merge and sync. I was happy for it to do so. My Stack Overflow took over, so I lost my description, reputation, badges, etc.

However if I look at my profile on Ask Different I can see all my previous activity including where I have gained rep, in fact some of the days where I have gained rep are higher than my overall.

Is there a fix, where I can get my rep and associated activity back?


UPDATE

I had over 700 rep on Ask Different. I have also noticed that when I looged onto the photography stack I was given +100 rep beacuse my Apple account had passed 200 (however the apple account displays my rep as 101.

share|improve this question
    
Can you clarify what happened, on which site did you have more rep than you do currently? –  Nick Craver Dec 6 '11 at 11:04
    
I have updated teh question to add this info –  Graeme Hutchison Dec 6 '11 at 11:06
    
I think a rep-recalc would fix it. Most likely just a visual/caching bug. –  Time Traveling Bobby Dec 6 '11 at 11:07
    
@NickCraver: See here. –  Time Traveling Bobby Dec 6 '11 at 11:08
    
Thanks @Bobby seems a likely solution. How can this be done? –  Graeme Hutchison Dec 6 '11 at 11:10
    
Manually add /reputation to the main site link - apple.stackexchange.com/reputation - there's a recalculate button at the bottom. Don't click it yet. First check the value that it thinks is your reputation and second wait a while for the team to check things out. –  ChrisF Dec 6 '11 at 11:12
    
@ChrisF can you pop that in as an answer? it worked for me. –  Graeme Hutchison Dec 6 '11 at 11:14
    
Just visit your reputation page. Nonetheless, keep Nick up-to-date so he can repro that. –  Time Traveling Bobby Dec 6 '11 at 11:15
    
@Arjan I used an email address to login to Stack overflow while in Ask Different, it then saw I was had 2 accounts and asked to merge and sync. I was happy for it to do so, but not happy about losing rep (which is now sorted) –  Graeme Hutchison Dec 6 '11 at 11:16
    
I will edit my description and picture manually as these were also lost. Thank you for all your help. –  Graeme Hutchison Dec 6 '11 at 11:17

1 Answer 1

up vote 10 down vote accepted

We had a deadlock issue on that database (which happens very rarely, but does happen with the level of traffic we get) at the exact moment the auto-recalc of your reputation was being performed, so it bombed out and left your rep at 101 on ask different.

I've recalced you there as well as fixed your missing 100 rep association bonus here on meta as a result (since, because of the lack-of-recalc, you didn't have a 200+ rep user at the time you signed up on meta).

This also helped me find the annoying bug where the accounts panel in the profile shows a different rep than the giant indicator at the top (fixed!), so thanks for having this issue :) Please comment here if there are any other remaining ill-effects and I'll see what we can do to resolve them.

share|improve this answer
    
Thank you for your help, I nearly gave in. While merging like i said there was an issue where my profile picture was removed, but again, I can fix that manually. –  Graeme Hutchison Dec 6 '11 at 11:46
    
Would that fixed bug apply to Different reputation in my profile page, is it a bug? too? –  Arjan Dec 6 '11 at 11:47
    
@Graeme - Ah yes, sorry not much we can do there...since it's email based and you're using quite a few different emails :) You can however add those emails to your existing gravatar account and give them all the same picture if you like... –  Nick Craver Dec 6 '11 at 11:48
    
@Arjan - Yes indeed, I was just searching to status-completed that, thanks! –  Nick Craver Dec 6 '11 at 11:49
    
@NickCraver I also lost a Bronze badge, cant remember which one. That doesnt help get it back, but it may help with you implementing a future fix –  Graeme Hutchison Dec 6 '11 at 12:04
    
@NickCraver stackexchange.com/users/333465/graeme?tab=accounts this page still says I have asked and answered 0 questions. –  Graeme Hutchison Dec 6 '11 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .