What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

When I answer a question on Stack Overflow, it appears as an answer on my laptop, as usual.

However when I view it on my iMac it's not there until about 3-5 hours later.

The same thing happens vice-versa.

This makes it almost impossible to have an answer accepted in time before another answer comes in.

I think you guys working at Stack Overflow should look into this bug.

I'm running Microsoft Windows 7 on my laptop with Google Chrome Dev and Apple Mac OS X Lion on my iMac with Google Chrome Stable.

EDIT 1: Here is a link to a recent answer

EDIT 2: I've e-mailed a couple of my friends and he can't see my answer, so it's not my computer's or my ISP's fault. I and a couple of my friends have eircom, some of them have UPC, and the rest have Vodafone.

EDIT 3: I'm not behind a proxy, VPN, Tor, or anything like that.

share|improve this question
    
"This makes it almost impossible to have an answer accepted in time before another answer comes in." There is a 15 minutes waiting time for accepting answers, to prevent exactly this, premature accepting of an answer. I'm pretty sure other answers will be added in the meantime, depending on the popularity of the question. Edit: This comment was made before the time was added. –  Felix Dec 18 '11 at 11:49
    
I can see your last answer just fine. Is the timestamp also wrong of the answers, or are those correct? –  Time Traveling Bobby Dec 18 '11 at 12:10
    
@Bobby I can't see it on my laptop yet –  Anish Gupta Dec 18 '11 at 12:12
3  
Well, clear the browser cache. If it isn't there then...well...try another browser. If it isn't there then...uuuhhhh...aggressive ISP caching? –  Time Traveling Bobby Dec 18 '11 at 12:13
    
Now we need your geographical location, including that of your friends. Maybe one the CDN servers is misbehaving. –  Time Traveling Bobby Dec 18 '11 at 15:23
    
@Bobby Tried clearing everything (history, cache, cookies, bookmarks, passwords, Autofill, downloads), still doesn't work. It's not aggressive ISP caching because as I said in the question lots of my friends aren't seeing anything. –  Anish Gupta Dec 18 '11 at 15:27
    
Does it happen on meta too? (Try posting an answer to this question, and add a comment here - that seems to work fine). Do you have any currently "invisible" answers, and if so on which question? (Your last answer is timestamped real close to the question's post date.) –  Mat Dec 18 '11 at 15:29
    
@Bobby I'm in Co. Dublin, Ireland. My Latitude/Longitude is according to Google Maps 53.346629,-6.424389. –  Anish Gupta Dec 18 '11 at 15:29
    
Okay, maybe we'll find somebody else from around there...but in the mean time, could you try out a proxy-service to check if your answer is showing up there? –  Time Traveling Bobby Dec 18 '11 at 15:31
    
@Mat I need to wait 4 hrs. I don't currently have any "invisible" answers. –  Anish Gupta Dec 18 '11 at 15:31
    
@Bobby I'm not big in this subject, can you recommend me one? –  Anish Gupta Dec 18 '11 at 15:34
1  
@Bobby, I thought the CDNs only serve static content? –  Arjan Dec 18 '11 at 15:43
    
@Arjan: Whoops, I was under the impression that the whole network is served by the CDN servers...my mistake. –  Time Traveling Bobby Dec 18 '11 at 15:45
1  
I've changed the tags into bug again, as that seems to be what you're thinking. But I really cannot imagine why one computer in your place would show the question differently than others using the very same internet connection. Are you logged in into SO on both computers? What if you use some private browsing mode? (Beware that ISPs might use proxy servers without you having to configure anything for that, but it's unlikely that different ISPs would use the same machines for that.) –  Arjan Dec 18 '11 at 15:47
2  
Just to be sure: your friends know they shouldn't be looking for your real name, right? And that the sort order might be different? What do they see for "asked/answered .. hours ago"? –  Arjan Dec 18 '11 at 15:54

2 Answers 2

Assuming you looked at the question on one computer, then posted using another, then looked using the first again:

The servers tell your browsers (and possible proxy server) to cache for 1 minute at most:

Cache-Control: public, max-age=60
Expires: Sun, 18 Dec 2011 12:29:36 GMT  
Last-Modified: Sun, 18 Dec 2011 12:28:36 GMT
Vary: *

So somehow your computers or (your ISP's) proxy server is caching far too long. If a proxy is behaving badly, then explicitly enforcing a refresh might not work either.

But it's surely an issue with your computers, or your connection/ISP.

share|improve this answer
2  
Not-so-fun fact as for badly behaving (hidden) ISP proxy servers: Hijacked session: Signed in as someone else. –  Arjan Dec 18 '11 at 13:24
    
An employee from my ISP came to my house and checked it. He said that there should be nothing wrong. –  Anish Gupta Dec 21 '11 at 17:09
up vote 0 down vote accepted

I changed my ISP from eircom to upc.

Fixed now and browsing is much, much faster!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .