What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

This appears to be the same or similar issue as this, though it is not fixed.

I had noticed it intermittently over the last week.

On a refresh of the Newest Questions page, questions that were there are gone, only older ones appear. Several refreshes later all is well in the world.

enter image description here


This just happened again - some questions were marked "3 minutes ago", a refresh and they are gone and I am only seeing "6 minutes ago", even though there are newer questions.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

And at exactly the time it happened, we were building/deploying Stackoverflow. Whether it was the deploy, or simply the fact of picking up a different server (as they cycled), simply: for a brief moment, the cache was slightly older than you had before. This particular cache is self-managing, and when it notices that it is stale, it automatically kicks off a task to freshen itself in the background - but continues serving the marginally older data while it does so (so as not to delay requests).

Basically, I'm not sure we need to change anything here. It is a rare event, only exists for a few seconds (typically while we deploy), and is self-fixing within a few seconds.

share|improve this answer
    
Fair enough. It simply felt like a bug. I have seen this last for a minute or so. –  Oded Jan 3 '12 at 10:50
    
@Oded what is the exact URL of the page you see this on? we also have top-level caching of the page contents, which might extend the duration a little. If you confirm the URL you are using, I'll see if we can make the refresh kill the page level cache –  Marc Gravell Jan 3 '12 at 10:54
    
    
@Oded hmmm.... no explicit additional cache in there; I assume it was simply taking a few seconds to refresh itself (immediately after an app-pool reload, etc) –  Marc Gravell Jan 3 '12 at 11:08
    
Possibly. Does this really explain seeing newer posts disappearing from the page? As you said, it does end up self-fixing, but sometimes the cache would be several minutes out of date (I have seen 9 minutes). –  Oded Jan 3 '12 at 11:16
    
@Oded yes, if we are cycling the servers. That particular cache is somewhat complex; we snapshot the data literally at random, between 5 and 10 minutes. When reloading from an empty app-domain, it loads the snapshot data, which could be as much as that out of date, yes. It will catch up soon, though. –  Marc Gravell Jan 3 '12 at 11:25
    
Fair enough... Had my share of multiple cache levels issues. Looks like this is here to stays... Happy to see this [status-declined]. –  Oded Jan 3 '12 at 11:26
    
This just happened (assuming you are moving from rev 2012.6.11.2858 to rev 2012.6.11.2864) - though now the newest entries are a week old! I am seeing stuff from June 4th as new :( And I am not seeing a return to normalcy either. –  Oded Jun 11 '12 at 12:13
    
@Oded on where? I just switched something over - it should fix itself momentarily. But: where are you seeing it? –  Marc Gravell Jun 11 '12 at 12:14
    
SO: stackoverflow.com/questions?sort=newest –  Oded Jun 11 '12 at 12:15
    
@Oded k - switching it back... I need to give that switchover code some love :( –  Marc Gravell Jun 11 '12 at 12:18
    
Ta. That looks better now... –  Oded Jun 11 '12 at 12:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .