What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I cannot log in to Stack Exchange chat.

If I check the Login help page, I get the following error.

Test 5: Communication with stackauth.com – failed
- IFRAMEs – ok
- Referrer – ok
- JavaScript – ok
- Storage – ok

We were not able to communicate with stackauth.com. Please make sure that you allow embedding of <iframe>s from remote sites into web pages, and that you allow this site and stackauth.com to communicate with each other.

I use Firefox 8 with NoScript and RefControl extensions, so I guess I have somehow to appropriately set referrers.

Update:

I have tried to enable and disable those two extensions in combination:

  • If RefControl is enabled, regardless of activation status for NoScript, the result is as described above;
  • If RefControl is disabled, regardless of activation status for NoScript, the result for referrer check is KO;

How do I fix this problem?

Is it possible to login to chat with Firefox 8?

share|improve this question

migrated from meta.askubuntu.com Dec 29 '11 at 14:56

This question came from our discussion, support, and feature requests site for Ubuntu users and developers.

    
Doesn't it work if you whitelist both domains in both extensions? (I don't know RefControl) –  Stefano Palazzo May 29 '11 at 23:56
    
By "KO", do you mean "OK"? In other words, you can log in? Then it's clear that it's RefControl that is making your browser misbehave. Btw, there are many people who can login to chat with FF4 -- including myself. If you positively have to use a broken browser -- does the IE7 ghetto login work? askubuntu.com/users/chat-stackexchange-login –  balpha May 31 '11 at 19:40
    
@balpha With KO I mean KO (Indeed I installed RefControl appropriately to make sites such as Launchpad or StackExchange chat to work). Clicking the link in your comment above, I get this: chat.stackexchange.com/login/global-fallback –  igi May 31 '11 at 21:58

4 Answers 4

Add stackauth.com domain to the NoScript exception list.

share|improve this answer
    
stackauth.com is already in my exception list. –  igi May 30 '11 at 0:34
    
you should comment on why it did not work for igi. –  user2987828 Nov 30 '13 at 21:44

I succeeded in logging here with noscript and Requestpolicy (similar to RefControl). The most important is to ask for alternative authentification, then to enter https://openid.stackexchange.com in the openid field.

I have whitelisted in noscript:

ajax.googleapi.com, stackexchange.com, sstatic.net, the hostname hosting the question and answer sites you are posting on.

sstatic.net is only necessary for chat rooms. None of them are necessary to post an answer or to log in.

I have whitelisted in Requestpolicy:

stackexchange.com, ajax.googleapi.com, stackauth.com, google.com, sstatic.net.

google.com is for the periodic captcha checking that you are not a robot. sstatic.net is for up-down voting, it is not necessary just to post answers. stackexchange.com, ajax.googleapi.com and stackauth.com are not necessary just to post answers. stackauth.com is not necessary to make the inbox icon work.

Note: I am updating this post by taking out one by one elements from the whitelist. If it does not work for your config, look for second revisions of this post (and then add comments about your config).

share|improve this answer

Since test 3 has succeeded (otherwise test 5 wouldn't even run), and all the in-IFRAME tests are okay, this suggests you have enabled same-domain postMessage, but disabled it for cross-domain communication.

share|improve this answer
    
I looked for this cannot of settings in both extension, tricking as much as I could. No success... –  igi May 30 '11 at 19:06
    
@igi have you tried turning the extension off by one and testing again? That would at least tell you which of the two it is. –  balpha May 30 '11 at 20:02
    
done; no improvement. Question updated according results I found. –  igi May 31 '11 at 18:54
    
NoScript disables XSS (Cross-Site Scripting) by default. If you whitelist *.stackexchange.com, or tell NoScript to not activate on stackexchange.com, then it should work. I ran into this issue myself. –  Thomas W. Jul 1 '11 at 15:36
    
Please update your answer with why this did not work for user igi. –  user2987828 Nov 30 '13 at 22:14

This may not be a direct answer to your question, yet I'll post this answer because I've encountered the same login problem using the ScriptNo extension for Google Chrome.

My settings

  • whitelist
    • *.stackauth.com
    • *.stackexchange.com
  • respect same domain (preserve same-domain elements): disabled
  • sort by domain (sorts URL lists by domains): enabled
  • Referrer Spoof: Off
  • Block Click-Through Referrer: enabled

In my case, I had referrer spoof set to same domain. Changing it to off solved my problem.

Other

AdBlock can also cause login problems - I don't really know why. But by trial-and-error I found that adding the following elemets to the list where AdBlock is disabled helps:

@@||stackexchange.com/$document
@@||chat.stackexchange.com/$document
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .