What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

When I try to log in to StackExchange with my openID, I get this mess:

Unable to log in with your OpenID provider:

The openid.return_to parameter (http://android.stackexchange.com/users/authenticate/?s=cf97...795&dnoa.userSuppliedIdentifier=https://id.mayfirst.org/abh) does not match the actual URL (http://android.stackexchange.com/users/authenticate/?s=cf97...795&dnoa.userSuppliedIdentifier=https://id.mayfirst.org/abh&openid.ns=http://specs.openid.net/auth/2.0&openid.mode=id_res&openid.op_endpoint=https://id.mayfirst.org/openid/provider&openid.identity=https://id.mayfirst.org/abh&openid.claimed_id=https://id.mayfirst.org/abh&openid.return_to=http://android.stackexchange.com/users/authenticate/?s=cf97...795&dnoa.userSuppliedIdentifier=https%253A%252F%252Fid.mayfirst.org%252Fabh&openid.response_nonce=2012-01-03T01:10:44ZNHDM&openid.assoc_handle=2012-01-03T01:10:44ZFVZB&openid.sreg.nickname=abh&openid.sreg.email=&s=cf97...795&dnoa.userSuppliedIdentifier=https://id.mayfirst.org/abh&openid.signed=op_endpoint,return_to,response_nonce,assoc_handle,identity,claimed_id&openid.sig=+sP8d...HWSQ4=) the request was made with. 

There doesn't seem to be any way to access that login anymore. I can't figure out whether the issue is with Stack Exchange or my OpenID provider, but my OpenID provider hasn't been able to resolve it and it only happens on stack exchange.

Ideas?

share|improve this question

migrated from stackoverflow.com Jan 3 '12 at 1:23

This question came from our site for professional and enthusiast programmers.

    
FWIW, my accounts have been merged. So my personal problem has been solved. The larger OpenID failure remains. I could call the question "answered" even though it hasn't exactly been explained. –  Amanda Jan 3 '12 at 20:16

3 Answers 3

Please take this opportunity to set up multiple OpenID providers for your account, so you can always get back to your account if one provider dies or ceases providing log in information for Stack Exchange sites or throws away your user data for some reason.

share|improve this answer
    
Excellent advice; I just added Facebook and Google log ins to my SE account, which had a MyOpenID log in already. +! –  Andrew Barber Jan 3 '12 at 19:16

I just experienced that as well and found out that it was because I was trying to log in via https://android.stackexchange.com (mind the S in HTTPS).

Once I changed to http://android.stackexchange.com (and put the whole stackexchange-network on my https-whitelist) the login via openid worked again.

I also saw "http://android.stack..." in the error message but my guess is you got to the login page via https.

EDIT: interestingly enough I just tried that at https://apple.stackexchange.com and openid login worked there. So my guess is either that was a temporary issue or the apple-site is not affected.

share|improve this answer
    
No dice. I get the same behavior on both http and https. –  Amanda Jan 3 '12 at 20:16
1  
This worked for me, though disable https is a bit disappointing. –  Guandalino Jan 5 at 17:12
    
By the way: this error still persists. I just experienced this on ux.stackexchange.com. –  masterjo Jan 5 at 21:02

I was able to write to Stack Exchange support from the email address associated with my original account and have them merge the two accounts. So I still don't know what's wrong with Mayfirst's OpenID but I do have access to my account again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .