What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

Can anybody confirm, that http://ajax.googleapis.com is blocked by OpenDNS' phishing filter?

Im asking, because StackOverflow (and maybe all others in the network) loads jQuery from this domain.

share|improve this question
    
I'm using OpenDNS and it's working fine for me. –  uɐɯsO uɐɥʇɐN Jan 4 '12 at 7:17
1  
I confirm!!! I'm switching to local jquery files. –  lg. Jan 4 '12 at 8:43
    
Same for me, included jquery locally now and everything works again. Hope OpenDNS will fix that soon. –  Sn0opy Jan 4 '12 at 8:50
    
@GeorgeEdison, Just a guess, but if you've disabled the phishing protection in the OpenDNS control panel then the site will not be blocked. –  Matthew Steeples Jan 4 '12 at 9:54
2  
I can confirm the problem and was able to get around it by going to my OpenDNS Dashboard Settings and telling it to never block the ajax.googleapis.com url. –  martineau Jan 4 '12 at 10:20
    
@martineau: thanks for this - I tried this and can confirm that it fixes the problem for me too –  Paul R Jan 4 '12 at 10:36
1  
It seems to be fixed (for me anyway, now returning a 404 from Google). –  Mat Jan 4 '12 at 11:21
2  
According to a response towards the end of this thread forums.opendns.com/comments.php?DiscussionID=12755&page=1 ... they've now delisted it and looking into why it was listed in the first place. –  Chris J Jan 4 '12 at 12:04
    
Yep, even the DNScheck shows original IPs again. But the cache still has to be refilled / -freshed to make SO work again. –  Sn0opy Jan 4 '12 at 12:06
add comment

6 Answers

up vote 13 down vote accepted

Edit: This is fixed now


It is. I switched to using OpenDNS, and got this when I tried going to http://ajax.googleapis.com/:

Screenshot of the blocked page

And meta no longer worked:

Screenshot of the meta error bar


You can also confirm using the CacheCheck tool:

Screenshot of the CacheCheck results

share|improve this answer
    
Heh... I wonder why it's working for me... –  uɐɯsO uɐɥʇɐN Jan 4 '12 at 7:27
    
@GeorgeEdison Caching? Maybe it just went down; I would think somebody would've reported it by now if it were a persistent issue –  Michael Mrozek Jan 4 '12 at 7:28
    
That's the only explanation I can think of - I just double-checked that my router was indeed set to use OpenDNS's servers for DNS resolution. –  uɐɯsO uɐɥʇɐN Jan 4 '12 at 7:32
    
When I checked, they all said "NXDOMAIN :: The domain is not in the Domain Name System (DNS)" –  animuson Jan 4 '12 at 8:31
add comment

The block seems to have been lifted now.

Kudos to the OpenDNS team, not only did they resolve the problem quickly but they also sent an update email (I had earlier reported the problem via the feedback option on the block page).

Hello,

I have de-listed the domain on our servers and forwarded this to our Phishtank team to investigate why it was listed and take the appropriate measure to prevent this from happening in the future. You may need to clear your cache and flush your resolver. If you have any other problems please let us know.

Daniel Gifford

Support Manager

If only other big service providers were as responsive eh?

share|improve this answer
2  
Got that email as well. –  jrtc27 Jan 4 '12 at 12:26
add comment

It just went down within the last hour for me. Strange thing is if I go directly to one of the hosted libraries, I get a 404 not found error, and not the phishing issue. I do have enterprise level support with opendns and filed a ticket with them. It could be an issue on Google's end. maybe one of their locations went down causing a bunch of 404's from opendns's network stack, which caused a flag to mark it as phishing. I do notice the Dallas center seems to not respond to the cache query.

share|improve this answer
    
I think you receive that 404, because OpenDNS didn't cache the file anymore. ajax.googleapis.com points to the OpenDNS cache server now, not to the "real" server anymore. –  Sn0opy Jan 4 '12 at 8:51
    
"the Dallas center seems to not respond to the cache query" - the Dallas center doesn't respond at the best of times :P –  robinjam Jan 4 '12 at 9:21
add comment

How to resolve this problem....sorry i had to use the answer box because i am unable to comment. I am using chrome and getting the same error for last two hours...can't check new messages, comment or do anything....

I have no extension or plugins installed. Everything regarding the javascript is enabled....I don't use openDNS and to be honest don't know what it's all about.....

Is there a workaround this problem or I need to wait for google or openDNS(what you guys talking about) to sort out this problem ?

share|improve this answer
5  
You should use an alternative DNS provider if possible, or edit your HOSTS file (if possible) (on Windows?), to route ajax.googleapis.com to 74.125.81.95 –  Matt Jan 4 '12 at 10:23
    
I hope i have done it right ....What i have done is opened the hosts file and entered this line -- 74.125.81.95 ajax.googleapis.com . This is what you wanted me to do right ?? –  Pankaj Upadhyay Jan 4 '12 at 10:40
    
The best way to check if you've done it right would be to see if the sites that were broken now work ;). –  Matt Jan 4 '12 at 10:46
    
Also worth noting -- if you use firefox, you may have to restart it for the changes to take effect (at least, I had to). –  Chris J Jan 4 '12 at 10:49
    
seems to be working :-) .. Thanks mate .... BTW since i don't use openDNS, this means that the googleapis Server itself are down at the moment, right ?? –  Pankaj Upadhyay Jan 4 '12 at 10:54
3  
@PankajUpadhyay: The servers' are definitely not down; it works for me. A few guesses; 1) Your ISP has a partnership with OpenDNS and you're using them even if you don't think you are. 2) Both your ISP and OpenDNS are subscribed to the same list of phishing sites which ajax.googleapis.com has been incorrectly added to. –  Matt Jan 4 '12 at 10:56
2  
@matt not inclined to remove this non-answer because it contains pretty useful information in the comments –  Jeff Atwood Jan 4 '12 at 11:15
    
@JeffAtwood: I've added a suggested edit to the accepted answer which replicated this info.... but I understand :). –  Matt Jan 4 '12 at 11:17
add comment

I spontaneously got the red banner with the message as well. Cleared DNS chache, cleared browser cache, even restarted the computer (which I rarely do), but still got the problem. Then I checked stackoverflow on a different computer of mine and noticed that it displays the same error message, then I realized it is not a local fault.

I'm using Simple DNS as a local DNS server and I have all domains forwarded to OpenDNS, but made an exception for ajax.googleapis.com and forwarded it to different DNS servers. While it was forwarded to OpenDNS, I was getting the pishing page from OpenDNS, now I just get a Google 404 with the broken robot, but everything's back to normal.

Changing any settings on OpenDNS didn't help much, so having your own DNS server running and managing DNS requests from it is good.

share|improve this answer
add comment

Yes OpenDNS seems to have problems with ajax.googleapis.com.

Try this: open command.com with Admin privileges and

  • Flush DNS: ipconfig /flushdns
  • Register DNS: ipconfig /registerdns

Wait for a few minutes and then try again. It should work. If the problem recurs, get rid of OpenDNS entries.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .