What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I was putting together a question on stackapps (quickly answered) asking about the new API filters. I wanted to link to some relevant API docs pages with the filters already specified, but it refused to recognize the URL in the markdown.

http://api.stackexchange.com/docs/sites#filter=!6ot9yf2tHd-0A(WH5pXrL9xuH_(.UL3EF-uBGL&run=true

Attempted as markdown: [some url](http://api.stackexchange.com/docs/sites#filter=!6ot9yf2tHd-0A(WH5pXrL9xuH_(.UL3EF-uBGL&run=true)

I don't deny the filter ID makes these URLs very ugly, so maybe it isn't supposed to work with exclamation points and parentheses. I simply ran the URLs through a shortener to fix the issue.

share|improve this question
    
You've got a couple of open parentheses there in the URL that are unencoded. They're hosing the Markdown. –  Robert Harvey Jan 12 '12 at 3:40
add comment

1 Answer

That link isn't correctly encoded. If you use the link button in the editor toolbar, any url entered there will be encoded.

share|improve this answer
    
It looks like the editor is doing an equivalent of JavaScript's encodeURIComponent, but that doesn't alter the characters of the filter at all. I'm curious if those characters only require encoding to markdown and not for overall URI requirements. –  patridge Jan 12 '12 at 13:59
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .