What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I'm facing a big issue with being able to answer or log in to Stack Overflow to ask question.

Fist I wanted to post an answer. I was given the option to log in or type email and name. I could not remember my login as I don't post much here so I typed my email and name. I was given the message that my email is already registered. So I chose to log in then. I was given many options to log in using several external logins. But I could not find simple user/pass field to type my login. So I chose stackexchange assuming this is the Stack Overflow login. But my email was not recognized. Also when I tried to recover my password my email was not recognized. So on one side Stack Overflow says my email address is registered and on the other side it's not recognized to log in with.

So I did register a new account with stackexchange. I was logged in, at least it seemed like it. I had a user name in top bar and when I clicked on it I got some overview page. Then I wanted to ask a question. After clicking ask and going next in the "do your home work" page I got a message stating I have to log in to ask questions.

In the top bar there was my user name, but saying that I have to log in. So I pressed log in, chose stackexchange login (this is only place where it asks for username and pass) and tried to log in but again login is not recognized there. So where can I log in by my user name and pass? This is going like this all the time, just stuck in the circle.

In the end I managed to post this question by logging in with my Google account which created another account for me, but still when I chose ask question going next on "home work page" it said again I'm not logged in. There I logged in with my Google account again and then I got the form to ask question finally.

I have to say that this is amazingly bad. And this is not like a temporary problem. I had the same issue a few times before when I ended up giving up asking because I did not have the time to find a way around it.

share|improve this question

migrated from stackoverflow.com Jan 27 '12 at 8:47

This question came from our site for professional and enthusiast programmers.

    
hmm odd, although I encountered a similar logging issue few months ago (mid year 2011) where my openId was not recognised at all and it seemed my credentials vanished. Luckily my desktop at home due to saved details had me logged in an I immediately added my Google details and made this my primary login. I later got to know if my not mistaken that the openId details got lost as a result of a server going down. Amazon? I really cant recall... –  MalsR Jan 27 '12 at 15:02
    
Stan, I had exactly the same problem and was forced to do similarly, i.e., use Google account to login. It seems to be a bug in the login process. Hope Stack Overflow resolves it soon. –  sammy Feb 3 '12 at 19:25
    
I've the same problem while I'm asking questions or trying to write answers, I'm logged in with Google acount –  Igal May 7 '13 at 6:55

1 Answer 1

Same problem here, but I solved it like this:

  • login with google account and then go to your profile and fill it with your information
  • now you are registered and have account on Stack Exchange

But the only different is when you want to login you should login with your google account never use Stack Exchange login.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .