What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

Using Arora 0.8 I'm unable to log in to any of the stackoverflow sites. Even though I'm logged in with Google ( confirmed by Gmail ), I don't appear logged in to SO (for example).


For context:

Arora is a lightweight cross-platform web browser. It's free (as in free speech and free beer). Arora runs on Linux, embedded Linux, FreeBSD, Mac OS X, Windows and any other platforms supported by the Qt toolkit.

Arora uses the QtWebKit port of the fully standards-compliant WebKit layout engine. It features fast rendering, powerful JavaScript engine and supports Netscape plugins.

share|improve this question
2  
declining this because I don't think it's our bug –  Jeff Atwood Aug 8 '09 at 18:30

1 Answer 1

UPDATE: RESOLVED

There is a feature in Arora to disable "tracking cookies" which is turned on by default. Generally this is a "Good Thing [TM]", but in the OpenID world it is actually desired.

To login with Arora you need to go into your preferences:

Menu > Edit > Preferences...

Privacy (Tab) > Cookies > Uncheck "Filter Tracking Cookies"


Original answer:

I too can not login via Arora... I get authenticated using (MyOpenID) and redirected to StackOverflow but I still appear as a guest user.

(Note: it works fine in Safari 4, and Chrome 2 on the same PC)

If I check out the headers coming back to StackOverflow from my OpenID provider (MyOpenID) I see the following:

(Using IE8 and Arora 0.8)

Identical

GET: /users/authenticate/?token=...
Connection: Keep-Alive
Host: stackoverflow.com

Different (IE = Internet Explorer, AR = Arora)

IE: Accept-Encoding: gzip, deflate
AR: Accept-Encoding: gzip

IE: Accept-Language: en-us
AR: {not sent}

IE: Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-shockwave-flash, application/x-silverlight, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, */*
AR: Accept: application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5


IE: Cookie:
            ASP.NET_SessionId=...
            _qca=...
            _qcb=...
            _utma=...
            _utmb=...
            _utmc=...
            _utmz=...
            openid_provider=myopenid
AR: Cookie:
            ASP.NET_SessionId=...
            _qca=...
            _qcb=...
            openid_provider=myopenid

The lack of the _utm(x) cookies makes me wonder... I checked in Firefox too and Firefox is getting the 4 _utm(a|b|c|z) cookies as well.

Update

There's an issue filed on the Arora bug tracking site (from July 2nd, 2009) that indicates issues logging into StackOverflow. (Arora Issue 507)... I'm "guessing" that the issue might be with Arora vs. StackOverflow.

share|improve this answer
    
I assume that's Windows, right? I'd like to disallow the Oh it's Linux solutions. –  Robert Munteanu Aug 4 '09 at 14:14
    
yeah, this on on WinXP SP3. I can log into StackOverflow on all of the following browsers (yeah I'm a geeky web dev)... IE6, IE7, IE8, Firefox 2, 3, 3.5, Chrome 1, 2, Opera 9.52, 9.64, Safari 3, 4. I've even tried changing the Arora Cookie settings to "Allow cookies from all domains" (not just the ones I navigate to) but it didn't help. –  scunliffe Aug 4 '09 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .