What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I have been using SO for a few hours this evening and all of a sudden, the edit buttons and preview disappeared. I am using Chrome and OS X 10.7. I just cleared my cache, but the buttons are still gone. Did I do something I am not aware of?

share|improve this question
    
If you can't see the 'edit' link, it's likely there is already a pending edit on the post. –  Jim Mar 21 '12 at 2:06
    
I have the same problem on all stack exchange sites. It has made it impossible for me to post a new question on SO, and if you look at the Chrome javascript console when trying to post a new page, you will see this: "Uncaught SyntaxError: Unexpected token ," –  JBCP Mar 21 '12 at 2:47
    
How do you know that the preview disappeared if you can't click on the "edit" link? –  Cody Gray Mar 21 '12 at 2:48
    
See this question: meta.stackexchange.com/questions/10131/… –  JBCP Mar 21 '12 at 2:48

4 Answers 4

up vote 5 down vote accepted

Thanks, a fix for this will begin rolling out in the next few minutes.

share|improve this answer

The prepareEditor call that sets up the editor has a dangling , in it, or (even worse) a double ,, if the variable to immediately show you Markdown help is set to true. Most likely explanation is that someone inadvertently introduced an extra comma when the discardSelector option was added.

All users who access the site using IE are impacted since it considers both conditions syntax errors, and anyone using a non-IE browser will be impacted by the second case.

share|improve this answer

It seems to be a problem with loading jquery from googleapis.com, and possibly your browser plugins. See this duplicate question here:

What happened to the formatting buttons?

which links to this issue here:

Employer blocks jQuery from Google, DOH!

share|improve this answer

I've just encountered another setup that can lead to this problem. I'm using the HTTPS Everywhere extension for Firefox. This means that Stackoverflow is loaded using https. The Google API site appears to be loaded via http.
As a result, Firefox sees the Stackoverflow page as 'mixed content' (secure and insecure elements on the same page), and blocks the insecure elements by default. Firefox indicates that is has blocked mixed content via an icon in the URL bar, but does not provide details on which content it has blocked.
Allowing the insecure elements to load resolves the issue.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .