What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I don't know why, but the last few days I haven't gotten any tag suggestions other than for the first one I type in. I have had to write one, cut it out, write another, paste the other one in, cut bot out, type the third one, paste the other two in, and so on.

I have the same problem in both Opera 9.64 and IE 8 on Vista.

share|improve this question
1  
A fix requires the browser specific code to read the cursor position in the input field. The method currently implemented seems to work only for FF/Safari. –  Jörn Zaefferer Aug 7 '09 at 7:12

5 Answers 5

I've updated the autocomplete plugin with some more IE-specific code, which seems to work for Opera, too. Please give it a try: http://bassistance-plugins.googlecode.com/svn/trunk/plugins/autocomplete/jquery.autocomplete.js

edit: this is now deployed

share|improve this answer
    
this is now deployed. tested in IE, works, Opera works but is a little quirky, which is.. well, Opera in a nutshell. –  Jeff Atwood Aug 13 '09 at 6:42
    
@Jeff: Wow. Now works on my machine. –  sharptooth Aug 13 '09 at 6:57
    
often on IE7 it overrights the wrong tag when I choose a tag from the list. –  Ian Ringrose Oct 22 '09 at 12:10

Seeing the same right now across SOFU.

Only the first tag is suggested. All others, no matter front, middle or back, will not offer tag suggestions.

Even with a cleared and flushed cache.

Opera 9.63

Since the recent deployment...

Doesn't matter where or which number tag you're trying to put in, first or third or fifth, whenever retagging a few posts on SuperUser, the cursor will always jump back to the first position and replace whatever is the first word. Annoying when trying to create even a sensible list of just three tags.

Doesn't feel like proper behaviour at all.

Workaround for Opera

One way to deal with this in Opera is to type the tags backward.

Type in one and when you're done, hit Home or whatever your keyboard of choice does to get you back to the start of the input area. Then type a space and go back again to the front of the input. Now type up the next tag and it will suggest it and prefill it properly. Return to the front and pad with that leading space for each tag you want to include

share|improve this answer
    
Yeah, status-reproduced in Opera 9.64 OSX –  Ian Elliott Aug 6 '09 at 14:07
    
status-reproduced in Opera 9.64 Windows 2000, will check under linux at home. –  perbert Aug 6 '09 at 16:52
    
Same problem here (opera 9.64/Ubuntu 9.04), very annoying. Thanksfully it's very easy to disable javascript in Opera, so I can type the tags, but I don't have the suggestions. –  Manu Aug 18 '09 at 19:51
    
Confirmed . –  Svish Aug 24 '09 at 16:31

Response from Jörn Zaefferer (the author):

Well, in this case its just the browser-specific code that is missing to read the cursor position in the text input, as mentioned in my previous mail.

I'm sure there is some obscure way to solve that in IE; not idea about Opera. Maybe ask on Stackoverflow about that?

Are there any Q's on SO about this?

share|improve this answer

When have you tried this? The feature was fixed sometime yesterday.

Edit:
The functionality you describe is not related to the newly fixed tag completion. Previously it would auto-complete only the last tag in the box, which is different than only completing the first. In either case, try it again today.

share|improve this answer

Works for me (SO & MSO, FF 3.5.2)...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .