Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I have tried to create my profile on yesterday. I observed that on the right-hand side, there's an option to make my profile public. I clicked on the button that says 'make profile public'. After that what I had was the below image.

How to create a public URL?

I have tried typing into the text box expecting that some script might get invoked to check what I am typing and give me a save button if everything was right. But no success.

share|improve this question
I always thought you just type in some kind of name and it would be automatically saved once you do something else on the page... Then you can navigate to your profile by just following the link. e.g., I have it set as jeffmercado so the link I get is – Jeff Mercado Apr 14 '12 at 3:54
Well, even I thought the same. But it didn't work out for me. Is this a bug then? If so, how to notify to stackoverflow about it? – Goje87 Apr 14 '12 at 4:07
Well, just like this. The Careers folk have already been notified... – Shog9 Apr 14 '12 at 4:26
@Goje87:You are currently notifying the same. Have you checked by refreshing Javascript again(ctrl+F5)? – Somnath Muluk Apr 14 '12 at 4:28
Is this broken AGAIN/ – Warren in Toronto Oct 16 '13 at 15:52
up vote 11 down vote accepted

Yes, this is broken right now. We're doing some network maintenance right now and I'll have a fix deployed shortly thereafter.

Edit: FIXED!

share|improve this answer

For a quick and dirty work-around, I found that if you use Chrome's developer tools (or any other live page editor) you can navigate and find that the form for that part of the page which has an ID of "public-route-form"

First, fill out the URL and check (or not) the search engine indexing, then go to the javascript console and enter:


You should then see the JSON response:

{"Success":true,"Message":"saved!","Summary":"\r\n        Your profile is \u003cstrong\u003ecurrently public\u003c/strong\u003e at \u003ca class=\"route-link\" href=\"/<YOUR_URL>\" target=\"_blank\"\u003e/<YOUR_URL>\u003c/a\u003e\r\n    "}

That should at least get your public URL up until the bug gets fixed. It worked for me anyway!

share|improve this answer

You should enter a unique name. After it public option become able to click.
When You enter occupied name You will get (picture one).
If name is available system save it automatically and after this action You can make profile public (picture two).

enter image description hereWhen You anter occupied name You will get:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .