I'm trying to write a post for Cooking's new blog, but when I try to insert an image, all size options (except for "full size") are disabled. The full-size is 1097 × 1462, and the thumbnail, medium, and large sizes are all set less than that under Config->Media.

Is there something that I need to do to get scaling to work, or is this a server issue?

edit: According to a support thread on the wordpress site, this is caused by gd not being installed on the server. (And a bunch of other links say the same thing, too.). So sounds like a server issue.

share|improve this question
    
Ill take a look at installing gd on the server for you, it shouldn't be a problem. –  Zypher Apr 25 '12 at 5:13
add comment

2 Answers

up vote 4 down vote accepted

I've installed libgd and php-gd on both nodes of the cluster running the wordpress network. Image scaling is up and running now.

share|improve this answer
    
Seems to work for new images, I guess it scales when you upload them. Easy enough to re-upload. Thank you. –  derobert Apr 25 '12 at 18:38
add comment

Blogoverflow uses Wordpress, so it's a bit difficult for Stack Exchange to fix things like that. The easiest solution (and what I usually do for blog posts) is to just resize images manually to the desired size before uploading.

Incidentally, if you're interested in seeing better blogging features better integrated with the site, check out this proposal: Using the Stack engine for the blog – a long-term idea for maintaining a healthy blogging culture

share|improve this answer
    
That doesn't work so well when you want to have it clickable to enlarge. Well, you could make it work, but then you'd have to manually upload two sizes, and deal with setting a custom link each time. Googling around, its supposed to work, but apparently gets grayed out e.g., if you don't have gd installed on the server. wordpress.org/support/topic/wp-not-resizing-images –  derobert Apr 21 '12 at 8:14
    
Hm. In that case, perhaps they just need to install gd. –  nhinkle Apr 21 '12 at 16:11
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .