What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

Not that it's the biggest deal in the world (as I think the ID is really only used for styling) but the AJAX notifications letting you know activity has happened while you're on the page all seem to share the same ID:

screenshot showing ID's

Also an interesting aside, occasionally if two or more are on the page (using image above as an example) the in-line changes won't "update" on click until you show any new questions first--or so it works here. That is to say I can't see Toni's new edit until I've viewed the new question first (otherwise it just fades out, then back in leaving the question un-changed).

FF 12, BTW.

share|improve this question
2  
What - no 3D view? I am not impressed :) –  Geoff Dalgas Apr 27 '12 at 14:13

1 Answer 1

up vote 8 down vote accepted

I have de-duplicated the notification div ids and switched to something a lot more classy. Thanks for the bug - it will be squashed in the next build.

share|improve this answer
    
Thank you very much. With regards to the ajax edit notifications; are you able to see what I mean about the edit not coming through if the post has more questions to show? (i.e. you're on the page, a user edits post and you get an update, now more answers are available and you get that update--now you can't just view a single answer's update (it fades out and back in with no change)) –  Brad Christie Apr 27 '12 at 15:03
1  
Yes, I'll build now to fix this –  Geoff Dalgas Apr 27 '12 at 15:12
    
Is it also just me or do revisions to the question themselves (and the ajax notification) not apply question title changes (when applicable)? That is to say if a question gets edited (title included) only the body is updated on click and not the title as well. –  Brad Christie Apr 27 '12 at 15:52
    
Follow-up: It almost appears confirmed; You guys appears to be using partial views for your update, but the partial is only the question body and not the title as well. My guess is you'd need to make the view more inclusive, or use some form of JSON to fetch the title (when necessary). –  Brad Christie Apr 27 '12 at 15:57
    
p.p.s. I've posted a question for this issue. –  Brad Christie Apr 27 '12 at 16:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .