What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

Note: This is related but not a duplicate: Message signature was incorrect

When attempting to log in to any Stack Exchange site with any login option from Windows, I receive a "Message signature incorrect" error.

  • I've tried with Google, Stack Exchange OpenID, and MyOpenID
  • I've tried with both my account/email, and an account I began to create for my brother. Neither worked.
  • I've tried from every single browser I have and can find. I have cleared the cache, cookies, and all settings on each.

  • I've tried from two machines, both Windows 7, on the same network.

Edit:

Regarding network configuration (I would be paranoid about posting it, but any site I visit can get this information)...

  • I use no proxy at all. At least none I'm aware of.
  • The ISP is Comcast. IPv4, if that means anything.
  • Home connection, not work.
  • I use Covenant Eyes on both versions of Windows. In typing this, I realize that very well might be the problem, and I'll try to test on Windows without it ASAP.

What's going on?

share|improve this question
    
My guess would be some kind of invasive proxy between your machines and the Internet. Do you use an explicit proxy? What do you know about your network configuration? Are you at home, at work? If you don't want to post private information in a public space, write to the Stack Exchange team (team@stackoverflow.com, like it says at the bottom of the page) and tell them what proxy you're using, what ISP, and anything else you think might help. –  Gilles Apr 28 '12 at 18:44
    
@Gilles edited to add network information. –  Thomas Shields Apr 28 '12 at 20:17
2  
Covenant Eyes is going to behave like a proxy, only possibly causing trouble and not helping here...definitely report back after disabling this. –  Nick Craver Apr 28 '12 at 21:38
1  
@NickCraver that was the problem. :) For some reason it automagically fixed itself, too. –  Thomas Shields Apr 29 '12 at 0:46
    
(@Peter, not to stalk you about that &nbsp you're adding to Stack Exchange names, but I really feel it looks worse on small displays...) –  Arjan Apr 29 '12 at 11:19
add comment

2 Answers

up vote 2 down vote accepted

Covenant Eyes was the problem. Unfortunately, it fixed itself, so I'm not sure of the details of the problem, but when in doubt, just track the login process with Fiddler and set your web filter to allow every URL on the list.

EDIT:

It actually didn't completely fix itself, but the problem can still be fixed. The easiest solution I found was to restart Covenant Eyes and login immediately after restarting. Fortunately you only have to do this once per Windows session so it's not too much of a pain.

share|improve this answer
    
Nice! Interesting enough, one of their developers is active member here. :) –  Shadow Wizard Apr 29 '12 at 11:15
    
Hmm, the restart workaround doesn't seem to work for me. But it seems certain log in providers work for me while others don't. So I guess I'll use the providers that work, at least for now. –  Mike Henry Jul 25 '12 at 7:56
    
problem and work-around are also true/valid of other forums. Here is a post on another forum using OpenID... ironically the support forum for Covenant Eyes. Please click this and help my case for them to get this fixed. helpforum.covenanteyes.com/covenanteyes/topics/… –  Watki02 Jul 25 '12 at 15:08
add comment

I resolved the Covenant Eyes issue for StackOverflow by adding http://stackoverflow.com­/users­/authenticate to the filter allow list and restarting CE. (Log in to My Account at covenanteyes.com > Filter Settings > Block/Allow Lists)

If you are only using StackExchange's authentication, allowing https://openid.stackexchange.com seems to work as an alternative.

A Covenant Eyes customer support representative said, "With sites like this, the filter sometimes gets "stuck" trying to read through all the characters." (By "sites like this", I believe he/she is referring to URLs with long/complicated query strings.)

share|improve this answer
1  
This didn't work for me until I allowed access to the entire stackoverflow.com host. ie http://stackoverflow.com/users/authenticate wasn't enough for me to get access. –  charlesdeb Jan 20 at 10:50
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .