What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 129 Stack Exchange communities.

Here's a sample of my StackExchange Inbox this morning:

enter image description here

enter image description here

The apostrophe ' is being improperly/unnecessarily escaped to ' in the inbox.

It's also doing it to double quotes:

enter image description here

As well as ampersands:

enter image description here


No the title isn't bugged I was just making a joke

share|improve this question
15  
Expect to revert a lot of helpful edits to your title. In fact, I jumped in here specifically to fix it. Fortunately, I actually read your question. –  Al E. May 8 '12 at 13:21
    
Been seeing this today as well. I'd already posted a similar bug roots around –  Manishearth May 8 '12 at 13:22
1  
+1 just for the title. –  Anish Gupta May 8 '12 at 13:22
    
Aah meta.stackexchange.com/questions/128439/… Not a dupe, though –  Manishearth May 8 '12 at 13:23
    
Oh. I've been meaning to submit this for a while... stupid short-term memory loss. –  minitech May 8 '12 at 13:29
    
Yeah, I noticed this too! –  CoffeeRain May 8 '12 at 13:45
5  
+2 for making me think. -1 for doing it in the morning! –  Andrew Barber May 8 '12 at 13:48
1  
It appears you are channeling the spirit of Tim Stone. See You got your double encoded space in my tooltip. Oh those SE devs, will they ever learn =P –  jadarnel27 May 9 '12 at 13:34
1  
Interesting that the "hot questions" tab shows them correctly but the inbox is double-escaped. –  Kevin May 9 '12 at 14:40
1  
I also saw an & in my inbox with a notification of some messages for me in the E&R Moderator Chatroom, so it's not just this character... –  Kevin Vermeer May 9 '12 at 16:47
    
@KevinVermeer that's odd, I see normal ampersands in my inbox, not in the title of chat rooms though –  Ben Brocka May 9 '12 at 17:00
    
@BenBrocka - I'll do some "testing" & see if it's working now. <-- What do you see there? –  Kevin Vermeer May 9 '12 at 17:08
    
@KevinVermeer it's fixed now –  Ben Brocka May 9 '12 at 18:57

2 Answers 2

up vote 8 down vote accepted

This only relates to inbox items from chat, but yes: it was a bit dodgy for about 8 hours. This was noticed and fixed about 12 hours ago, so you should be fine now. It was entirely my fault; was trying to tidy up how markdown appeared, but it got a bit over-excited and over-encoded things. Always better than the alternative, of course.

share|improve this answer
    
Don't forget to fix the same problem in the career ads while you're at it. meta.stackexchange.com/questions/126603/… –  David HAust May 9 '12 at 23:16

It's also happening in the inbox at http://stackexchange.com/users/[User ID]?tab=inbox.

There, I was able to go back a couple days and find that older messages do not suffer from this problem:

enter image description here

The double quotes on "A" sizes were shown correctly on 05/07 at 14:24, but Teachers&#39; Lounge was messed up on 05/07 at 18:23, less than 4 hours later.

Hopefully that helps you narrow down to the commit that broke the encoding.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .