What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

I'm not totally sure this is a bug but I thought it to be unexpected behaviour and I can't find another reference to it here.

I've just seen the number of suggested edits shown in the top toolbar go into negative figures:

enter image description here

This happened while on the suggested edit queue page, after I had approved a couple of edits. As far as I'm aware I wasn't doing anything different from normal (but then again it's Friday so it's hard to say how much attention I was actually paying).

I have no userscripts/browser extensions that would be interfering with this.

share|improve this question
4  
The suggested edits counter is live updating now, just like vote counts on questions and answers. So this is probably a race condition related to that. –  Cody Gray May 25 '12 at 9:01
6  
Heh, how I wish Stack Overflows queue count was even close to -1 (it's @ 151). –  Matt May 25 '12 at 9:32
3  
@Matt I once checked out SO's queue when it was at three, and managed to clear them all before any new ones came in. True story. –  Pops Jun 2 '12 at 16:20
    
Related meta.askubuntu.com/questions/3292/… –  jrg Jun 5 '12 at 11:35
4  
I just got this, edit queue was at 6, I approved one and it went to 4! After approving the next 5, it went to -1. Seems to be the first edit approved that's the problem. This is way too common on slow sites to be a race condition. –  Ben Brocka Jun 8 '12 at 18:33
1  

2 Answers 2

up vote 5 down vote accepted

We have revamped the way suggested edits work as well as the counter. There were cases where the number could drift below zero due to caching. This should be fixed but please let me know if it happens again.

share|improve this answer
    
I've been keeping my eye on it; since the new review system went live I haven't seen it happen again –  Clive Sep 11 '12 at 17:34

I had this same problem on chem.SE, but I had a much weirder experience with it. Exact sequence of events

  • See (1) next to the mod link
  • Go to edit
  • Approve edit
  • Scroll up (on edit approval page which live-refreshes to the queue), see that there are no pending edits but the mod thingy shows (-1)
  • Refresh the page, all fixed now
  • Do other stuff for a minute
  • Come back to chem.SE, open a new tab, notice a (0) up there (?!)
  • Refresh, fixed

I've never seen a (0) up there before--especially after opening a new tab (I understand that the realtime updates may make a (1) into a (0), but in this case nothing new had happened on the site since I'd approved the edit. Also, that's only realtime, this was on a new tab).

Since this happened a minute after the review, it's not just a realtime update race condition. There seems to be some issues with the caching as well.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .