When I edited my answer to this question, I ended up with two answers:

enter image description here

Possibly an issue in the editing code?

share|improve this question
1  
I have had this issue before (I just can't find my post about it at the moment) –  amanaP lanaC A nalP A naM A Jun 18 '12 at 14:14
add comment

1 Answer

up vote 10 down vote accepted

According to the server logs, you did indeed request the inline editor, but then submitted the "Your Answer" form instead. And looking at the code, I can't see any way the submission route could accidentally become the wrong one.

I have to assume that you did really submit a second answer here by accident (maybe a back button was involved?), unless you can actually give reproduction steps for this; I'm unable to reproduce this or even come up with a remotely probable other explanation.

share|improve this answer
1  
I remember doing tab out of the edit area then enter to submit. The "Add Another Answer" button is not visible at that point. I'm using Chrome. –  Andomar Jun 18 '12 at 14:07
4  
Hence my idea with the browser's back button -- if you accidentally clicked it (some mice even have an extra button for it), and the browser re-fills the "add answer" text box with what you previously had typed, it appears at first glance that you're actually editing. –  balpha Jun 18 '12 at 14:12
    
I have one of those mouse buttons, let's assume that's what happened then! –  Andomar Jun 18 '12 at 14:16
    
@andomar we could do some kind of sanity check to make sure the exact same answer isn't posted twice, but as you can see, usually it's an edit submitted twice, so it wouldn't match anyhow. –  Jeff Atwood Sep 18 '12 at 5:45
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .