What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

Here I'm entering the tag active-directory...

Type activ

alt text

Type the letters -dire to differentiate from activerecord

alt text

Press TAB and wrong tag is inserted

alt text

Possible resolution: When pressing TAB a match against the currently entered text should be made.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

It's using the highlighted record. While the auto-complete could be made to be a little more intelligent, this certainly isn't a bug. The expected behavior is that if you press tab while a tag is highlighted, it will insert the highlighted tag...which is what this does.

Also, sidenote, I just tried this specific example, and it immediately switched to active-directory as soon as I hit the dash. Hitting tab selected active-directory.

share|improve this answer
1  
That's interesting. Which browser are you using? –  Alex Angas Aug 11 '09 at 12:38
    
Chrome on WinXP. <3 Chrome. –  Eric Aug 11 '09 at 12:54
    
Hmmm I'm on Firefox. Could be a perf issue. –  Alex Angas Aug 11 '09 at 13:27

I have this problem periodically when I'm entering tags, but after the question posts, I'm unable to reproduce the issue. Happens with IE7. From time to time, it'll replace the first tag with the one I've tabbed to select. Wish I had more info but it's very sporadic.

share|improve this answer

The completion lag thing also happens to me (firefox and chromium). It makes that other bug more annoying.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .