What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Stack Exchange blog is showing me the mobile site and won't let me exit on Chrome 21.

Could someone take a look? Thanks.

Edit I noticed it was with the special query string, that I can't exit it.

http://blog.stackoverflow.com/?blb=1

share|improve this question
    
Repro Chrome 20, Chrome 22. –  Manishearth Jun 23 '12 at 1:24
    
Repro chrome 19. EEEEK –  Ben Brocka Jun 23 '12 at 1:55
    
Not seeing this. Transient problem? cc @BenBrocka –  Shog9 Jun 24 '12 at 1:52
    
Not seeing this either on Chrome 19. Tried while logged in to Wordpress and not logged in to Wordpress (sometimes does odd things), but didn't see. Tried with and without special query string, no mobile site trap. –  Ellie Kesselman Jun 24 '12 at 11:19
2  
Didn't even know the blog has mobile version... can't see it though getting only the ordinary blog. Did you find what happened by now? –  Shadow Wizard Jan 7 at 14:49
    
@ShadowWizard I'm pretty sure it's due to the blog's caching being a bit haywire, but hard to say for certain. We can always just blame WordPress. –  Tim Stone Jan 7 at 14:58

2 Answers 2

Reproduced in chrome 31.0.1650.63 on windows 8.1, but only in an incognito window. Nothing much I can do about it except blaming WordPress...

enter image description here

share|improve this answer
1  
But why it happens only to some users? Same browser here, can't see that mobile version. –  Shadow Wizard Jan 7 at 15:31
    
@ShadowWizard: My hypothesis: race condition bug in the Wordpress mobile device detector. Shared global state flips the state for multiple visitors when only one uses an actual mobile device to visit the site. –  Martijn Pieters Oct 8 at 11:42
    
@ShadowWizard: I just saw the site flip to mobile, then on a later visit flip back to the desktop state. I had not changed a thing other than let a few minutes pass. –  Martijn Pieters Oct 8 at 11:43
    
I can now trigger it at will. Steps to reproduce: Use a mobile device, click on the blog link in the footer. Then visit the same link from a desktop browser, you'll get the mobile version. –  Martijn Pieters Oct 8 at 11:45
    
And I switched it back by using the exit mobile version link on my mobile device! –  Martijn Pieters Oct 8 at 11:47
    
This may be tied to IP address; e.g. it may be limited to others behind a shared IP address using a mobile device. –  Martijn Pieters Oct 8 at 11:48
    
@MartijnPieters We use some caching plugin (I forget which one). I wonder if that's the culprit here where it caches a certain view per IP/device/account? –  Anna Lear Oct 8 at 15:47
    
@AnnaLear: sounds like a plausible culprit. It probably won't support 'Vary:' headers, will it? Otherwise you'd include User-Agent in that. –  Martijn Pieters Oct 8 at 16:13

Looks like the caching plugin we use, WP Super Cache, is to blame. (Many thanks to Martijn Pieters for investigating and pointing me in the right direction.)

I'll see if we can tweak the settings to fix this up, but I'll be honest - fighting with Wordpress is fairly low priority at the moment.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .