Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I'm facing a recurring bug where I enter a discussion (mainly from Google) and then none of the commands (vote up, comment, add a response) works. They just don't work. No message error, no client inconsistency.

I've just tried to add a comment to one of my posts and needed to do it 3 times before it works ok.

Here is a screenshot with some console output and the state of the site:

I'm using Windows 7 with Chrome 19.0.1084.56.

share|improve this question

closed as too localized by Time Traveling Bobby, balpha Jul 2 '12 at 14:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browser? OS? Other details? – Aaron Bertrand Jul 2 '12 at 13:28
Just added the OS/Browser details. Any other to be more helpful? – Caio Cunha Jul 2 '12 at 13:38
How about a result from and/or loading times for a page that "breaks" using Chrome's developer tools? – Aaron Bertrand Jul 2 '12 at 13:41
You did clear the cache (pressing Shift+F5), did you? – Time Traveling Bobby Jul 2 '12 at 13:45
What's that superfish thing that's included in your page? – balpha Jul 2 '12 at 13:47
I've just made the test I believe it's not a problem with bandwidth, though. I'll try to reproduce the error with devtools opened. – Caio Cunha Jul 2 '12 at 13:48
Most likely some fancy browser extension you got either willingly or as result of installing something. Example. – Shadow Wizard Jul 2 '12 at 13:49
Disable all your extensions and try again. – Ryan O'Hara Jul 2 '12 at 13:50
I believe the problem was the Superfish thing. Read Later Fast was adding it. I just disabled it and the problem stopped. The same to GS. Can't know for sure, because the problem was not consistent, but I've tried many times and couldn't reproduce it. Maybe @balpha or ShaWizDowArd should make an answer so I mark it as the probably answer. Thanks for inputs and post clarifications and typos edits. – Caio Cunha Jul 2 '12 at 14:00

I see the same problems from time to time when 3rd party sites are slow to load.

For example, when I were to Shift-Reload the Users page on SO while browsing the site over HTTPS, could respond slowly.

As a result, any javascript that waits for the page load to complete (and on SO, that's a lot) will not work until the 3rd party resources have completed downloading.

You could try a different browser to see if their cache or DNS lookup implementation gives you faster results, but sometimes slow sites just break things and you have to be patient.

In other words: slow or broken internet connections break websites. This is not, however, a bug the websites in question can fix. If the JavaScript or other resources do not load, they do not load for reasons outside of the StackExchange sites' control.

share|improve this answer
I'm seeing this issue kind of frequently these days. I'm having the same problem with Grooveshark, for example. I added a screenshot with some console output. – Caio Cunha Jul 2 '12 at 13:32
If you have the same problem with other sites what makes you think it's a SO bug then? The basic premise is the same for GS; if resources load (very) slowly JS that waits for a complete page will be delayed. Sometimes severely. – Martijn Pieters Jul 2 '12 at 13:35
I believe the slowness may be involved, but its breaking the code, because the site doesn't get back to life, only with a refresh. Does it fit your toughts? – Caio Cunha Jul 2 '12 at 13:37
The refresh causes a) the current thread waiting for a site to respond to be stopped and b) retries the slow site, which could respond better now, depending on what caused the hung request in the first place. Bad internet connections can break a lot of things, including SO, but that doesn't make it a bug, per se. – Martijn Pieters Jul 2 '12 at 13:40
@CaioToOn If you are on a slow network then it's quite possible that requests for some JS files (critical to operation of certain functions on the site) time out. Therefore the functions necessary to vote/comment etc. simply aren't there; they're not broken. – Aaron Bertrand Jul 2 '12 at 13:40

Not the answer you're looking for? Browse other questions tagged .