What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I've created account for stackoverflow (by clicking change image and registering in gravatar). But picture doesn't shows. More then one day has passed since I've uploaded it. My gravatar gmail account is the same as my stackoverflow account. What is wrong?

share|improve this question

migrated from stackoverflow.com Jul 7 '12 at 12:02

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

My gravatar gmail account is the same as my stackoverflow account.

The email address on your account is not a gmail address (check your profile for the main email address associated with your account). You can either change that address to match the one registered with gravatar, or you can add the email address used for your Stack Overflow account as an additional address for your Gravatar account. Either way should cause the correct picture to be shown.

share|improve this answer
1  
And note, for Gmail, johndoe@gmail, john.doe@gmail and even johndoe+whatever@gmail are all the same. But: that's not true for Gravatar either. It should be an exact (lowercased) match. –  Arjan Jul 7 '12 at 12:17
    
Thank you. You are right. But I've changed my email and picture doesn't appear. Have I? –  Steve Yakovenko Jul 7 '12 at 17:46
    
@SteveYakovenko Hmm, I don't know; are you sure your email as registered with gravatar is precisely identical to the one you use on Stack Overflow, character by character? –  balpha Jul 7 '12 at 18:23
    
I've gave links to my profile screenshots... –  Steve Yakovenko Jul 7 '12 at 18:40
    
@SteveYakovenko I have deleted those (not sure you want that information to be public). What is the URL of the avatar image that the gravatar page shows for you? –  balpha Jul 7 '12 at 18:45
    
    
@SteveYakovenko The last link in on the bottom of the blue rectangle on gravatar (it says "link" in my language) should also show your picture. That's the one I I need. –  balpha Jul 7 '12 at 19:26
    
@SteveYakovenko This is what I get when I try to register on gravatar with your email address: i.stack.imgur.com/wXF8o.png See how the avatar it show is the anonymous grey shape? Somehow, your correct gravatar image isn't set yet. We're definitely using the correct email, so once the correct image is set, it should work. –  balpha Jul 7 '12 at 19:45
    
When I click my profile, I get two images: s001.radikal.su/2012/07/08/1bb89fac.png default ant mine. I can't remove default nor make my own to be default. –  Steve Yakovenko Jul 7 '12 at 20:20
    
OK, since noone can help me, let us consider this is a bug that SO actively doesn't want to fix... There are many people asking to fix that bug. –  Steve Yakovenko Jul 12 '12 at 9:42
    
@SteveYakovenko What are you talking about? You have found out yourself that this is an issue with Gravatar, not with Stack Overflow. You'll have to talk to them; there's nothing we can do about your Gravatar account. –  balpha Jul 12 '12 at 10:08
    
I've already sent them a message, no reply. Does it makes sence to deal with someone who doesn't care about their service? –  Steve Yakovenko Jul 12 '12 at 19:27
    
At last gravatar support have managed to update my picture. Though gravatar interface is very unfriendly and hard to understand yet. –  Steve Yakovenko Jul 14 '12 at 6:13

So the gravatar you uploaded is not displaying? If you've given Gravatar's servers time to update, check your image rating: most sites will only display "G" rated images, and you may have inadvertently rated your image differently.

You can check how your image will display by using this link: en.gravatar.com/site/check

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .