What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

So often when I post I get "An error occurred during submission." Resubmitting doesn't help and I am forced to refresh the page. At that point, I have to verify that I am human.

What happened to this site? I've been patiently waiting for months, maybe a year it to get better but I see no signs of improvement.

It can't be just me, because I have this issue across multiple browsers and multiple PCs.

enter image description here

enter image description here

enter image description here

enter image description hereenter image description here

enter image description here

share|improve this question

migrated from stackoverflow.com Jul 8 '12 at 22:18

This question came from our site for professional and enthusiast programmers.

2  
Note that this Question ironically went in without an error. –  user145973 Jul 8 '12 at 22:16
7  
I have never seen this. Perhaps you have a dodgy connection? –  Eric J. Jul 8 '12 at 22:19
3  
Maybe a year, but you're just now reporting a problem? You're very patient... –  animuson Jul 8 '12 at 22:20
2  
I've seen this many times while using mobile phone / tablet with bad 3G connection.. –  Sampo Sarrala Jul 8 '12 at 22:20
2  
I've never seen this on a proper DSL line. –  Pëkka Jul 8 '12 at 22:21
    
Whenever I refresh the page I'm always asked to verify that I am human. So I've stopped doing that. –  Neil Jul 8 '12 at 22:27
    
Yep, -2 for speaking the truth about a sacred cow. –  user145973 Jul 8 '12 at 22:27
    
Refreshing was the only way to clear the error. –  user145973 Jul 8 '12 at 22:27
    
I've worked at 3 companies in the last year with stable fast networks and access this site from multiple browsers on multiple including from home. The problems occur in every site. –  user145973 Jul 8 '12 at 22:30
    
I am not patient. I'm just cynical\realistic of the outcome of reporting it. –  user145973 Jul 8 '12 at 22:32
13  
"The truth about a sacred cow" suggests that other users are experiencing the same problems, but not speaking out because of their blind allegiance to the site and downvoting to censor you. That's a pretty ridiculous suggestion when you look at the stuff that gets asked on Meta. People will complain about the naming of fracking CSS classes, for God's sake. And any downtime, no matter how short, will result in five "why is Stack Overflow not reachable?" bug reports –  Pëkka Jul 8 '12 at 22:51
2  
I think you could have a valid question here (especially given one of your answers) if you consider rewriting the title and providing more details--which browsers? Operating systems? –  simchona Jul 8 '12 at 22:55
    
Multiple PCs (3 different laptops) and I have a desktop at home. What blows my mind is that you guys aren't saying "yeah, me too!" –  user145973 Jul 8 '12 at 23:28
1  
I have seen this many times. I never reported it because it is random and resolves itself quickly. –  bluefeet Jul 8 '12 at 23:29
2  
As mentioned in another comment. I'm thinking that the common thread is VPN. I've used both Nortel and Cisco and definitely had this issue. I will monitor my home PC which is certainly more reliable at least. –  user145973 Jul 8 '12 at 23:37

2 Answers 2

Looking at the traffic logs...

We've got no recorded errors (500s, and so on) from your account (or IPs your account has used) in the last 48 hours. I only see a handful of 404s, and they look legit (GET-ing POST-only routes or global auth denials [which are normal]).

That style error message will popup when an ajax request times out or otherwise fails to complete, it can be the result of a purely client side error.

If you want to try and capture what's actually failing when you're experiencing this problem (Fiddler, Chrome networking tab, whatever) we can take another look, but based on the data I've got on hand it looks like something network related is mucking things up on your end.

share|improve this answer
    
Trying to test while using Chrome Networking tab. Edit: It's working. –  user145973 Jul 9 '12 at 0:06
    
Test #2. Trying o see if I can get an error again. Before it was happening right and left/ –  user145973 Jul 9 '12 at 0:07
    
No luck. It works now. –  user145973 Jul 9 '12 at 0:07
    
I am trying to use the network tab of Chrome. It seems that the longer it takes before I commit a comment, the more likely the error occurs. I had the Chrome Network tab up a moment ago when I got the error. It was something showing a redirect from a company server. I tried to click to see if I could get more info, and I lost even that msg. This is the first time I am running it. I'll commit this is a min or two & prob get an error. –  user145973 Jul 10 '12 at 1:02
    
Unexpected response code: 302 :1 POST meta.stackoverflow.com/posts/comments/392156/edit 500 (Internal Server Error) jquery.min.js:4 POST meta.stackoverflow.com/posts/comments/392156/edit 409 (Conflict) –  user145973 Jul 10 '12 at 1:08
    
If I wait too long, I get an error that a comment can only be open for 5 mins. This is the first time that I ever waited THAT long. I don't consider this a system issue, of course. –  user145973 Jul 10 '12 at 1:09

Maybe there could be [Retry] link within some error boxes, when clicked it could try to resubmit request. I'm not sure if it's worth it if reclicking add comment (or like) button already does same request again.

Retry link in error box

How about it? Can it work without wasting resources for example if post is being migrated or deleted while trying to post comments?

share|improve this answer
    
I kid you not. I just closed Chrome and opened IE and tried to post a comment reply. The comment appeared to have been submitted w/o error but no comment appeared. ppoof. gone. This is anotehr common issue. It gets to the point where before I submit I put my post on my clipbaord. –  user145973 Jul 8 '12 at 22:51
    
@user145973 It seems that this would not give solution for your problem (if your connection is stable). There's something else going on. However this could help mobility users and users with unstable connection. –  Sampo Sarrala Jul 8 '12 at 23:06
    
Interesting theory about the realiability of the connection. However, as I noted, of my 3 employers in te last year and my home, none of the connections appear to be "stable" enough for SO to work reliably. Yet, my general browsing is without incident. I think it's a pretty safe bet that for every one person who reports an issue there are scores that just live with it. –  user145973 Jul 8 '12 at 23:13
    
This is a test post from my Desktop. Previous posts for this thread were from my work laptop while on VPN. –  user145973 Jul 8 '12 at 23:32
    
I mostly post from my work laptops, that all run Notel VPN client (and now Cisco). I believe that I also have issues from my personal PC but I mostly post from my work PCs. I will monitor it. –  user145973 Jul 8 '12 at 23:35
    
Wow, I thought I answered that question but that must've been a lost post. At my current job, I am running Windows XP SP2 with Chrome 20 and IE 8. My previous jobs all used Win XP too, and various versions of Chrome and IE. Since I switched to my personal Windows 7 PC my posts have been trouble free. I run no addins. –  user145973 Jul 8 '12 at 23:47
    
Corrction. Add-Ins displayed in image. I will disable all but Java. I have been using Code Library for years. I hope that's not it. –  user145973 Jul 8 '12 at 23:57
    
@user145973 Does your whole internet go through VPN? If it goes then there probably is other mangles too on route before reaching SO. I mean all those firewalls and sb routers (had problems with them in past)... Maybe you could try to do some stress testing with your connection. You should edit your post and include all information you provided here as comments to my post. –  Sampo Sarrala Jul 8 '12 at 23:57
    
I believe it does, because I cannot connect to teh Internet without 1st establishing a VPN conenction, though this wasnt the casse with my previous laptops from earlier employers. –  user145973 Jul 9 '12 at 0:00
    
@user145973 it's almost certainly an issue of the VPN being inbetween. You could talk to the IT department about configuring it such that your computer does not use the "default gateway on [the] remote network" (that's the Advanced TCP/IP settings name in Windows UI) to see if that alleviates this issue. –  jcolebrand Jul 9 '12 at 14:43
    
Not a bad suggestion to go through the corporate bureaucracy so all users within my company could access SO problem-free. That wouldn't help the users at my last two companies or (presumably) other companies. But I would think that the owners of the SO Exchange Q&A web app would want to fix it. –  user145973 Jul 10 '12 at 0:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .