What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

While cleaning the new and incorrect (in my opinion) tag from Stack Overflow today, I stumbled upon this question which had "Enter" that I wanted to format using <kbd> tags.

So I did and that's what I saw:

Horrified I went to perform some quick tests and found that whenever <kbd> tag contain five characters it will span two lines:

Enter Break 12345

Less or more are OK:

F1 F12 123456

Saw some weird things, but this has a place of honor. :)

I found a way around by injecting three fancy space characters:

Enter   

But it feels pretty hacky.

Browser: Chrome 21 - totally forgot I chose to install Beta versions whenever they are ready. :(

share|improve this question

closed as too localized by Mark Trapp, Toon Krijthe, Manishearth, animuson, Time Traveling Bobby Jul 16 '12 at 7:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
no-repro for me (Safari 5.1.6/OS X) –  nhahtdh Jul 16 '12 at 7:11
2  
It's not broken for me... Chrome 20 –  animuson Jul 16 '12 at 7:12
5  
Browser? And don't dare to say it is not an official released one... –  Time Traveling Bobby Jul 16 '12 at 7:14
1  
This may be related to this Canary bug I posted a while back. –  Manishearth Jul 16 '12 at 7:26
    
@Urist aka Bobby - blonde moment on my part.. the browser updates are so transparent I completely forgot I'm on Beta version of Chrome 21. –  Shadow Wizard Jul 16 '12 at 7:28
    
@Manish cheers, looks like you are right on spot - if this question is to survive please post this as an answer. :) –  Shadow Wizard Jul 16 '12 at 7:29
    
@ShaWizDowArd: Well, I dunno--the bare bones styling I mentioned over there doesn't seem to work. Looks like it's a similar bug, but with different causes. I'll post it as an answer anyway. –  Manishearth Jul 16 '12 at 7:33
1  
I put in a fix for this. it will be in the next prod build. –  Jin Aug 2 '12 at 14:12

1 Answer 1

up vote 4 down vote accepted

There was a similar bug in Canary a while back.

Here's the bug report; apparently it was fixed.

I'll mess around with the styling till I can figure out what's wrong.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .