Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

In the last couple of days, I seem to have lost a load of comment notifications. I'm used to the indicator being red virtually every time I log in - but I don't think I've seen it be red recently; there's been no indication of comments.

It's occasionally been light blue for the "general" notifications - it's possible that actually this has almost always been the case, and that reading those notifications has effectively wiped out the comment notifications.

Either way, it seems to be behaving differently recently, and definitely in a bad way for me. (Other users who are more interested in badges than comments, or who rarely get comments, may feel differently of course.)

Assuming there really has been a change, could someone in the know at least explain it so I know what to expect? (And ideally change it back, but...)

EDIT: The comments are still there, shown in the dropdown - but I need to check the dropdown to see if there are any new comments, and there's no indication which ones are new. (I need to keep going until I see the first one I recognize.)

EDIT: I normally use Chrome, but I've just tried it with Internet Explorer as well (and no SO windows open on Chrome). Still no red light :(

share|improve this question
@Pekka: Yes. Will edit that into the question. – Jon Skeet Jul 22 '12 at 8:55
Okay, this is very bizarre. I can now see a notification of "Guess not. What about this?" - but I can't see that on the question itself. I also can't see Pekka's comment I originally replied to. Perhaps Pekka's deleted them? – Jon Skeet Jul 22 '12 at 9:01
The first comment was mine. Apparently the system tells you about deleted comments but not... comments that were once there. – BoltClock's a Unicorn Jul 22 '12 at 9:01
@BoltClock'saUnicorn: Right. I've noticed that before - it's a bit disconcerting to start with, but not a big problem. Off to church now, so won't be up for more experiments for a couple of hours... – Jon Skeet Jul 22 '12 at 9:02
I deleted my comment after your edit, so that part is ok – Pëkka Jul 22 '12 at 9:17
As the red thing might be client side, what browser you have? Any chance you: 1) Switched browser 2) Upgraded to beta version (Chrome does it by itself sometimes) or 3) Installed some browser plugin/addon that might affect JavaScript? – Shadow Wizard Jul 22 '12 at 9:59
@ShaWizDowArd: I'm using Chrome 20.0.1132.57 m on Windows 7 - I believe I'm using the release channel. Note that I still get the notifications around badges/edits - just not comments. – Jon Skeet Jul 22 '12 at 11:02
So like you said, when you check the notifications the comment alerts also get reset as both reset upon clicking the Stack Exchange™ MultiCollider SuperDropdown™ - maybe it's worth trying to ask for feature request that will mark the inbox items as read only when actually clicking their tab. – Shadow Wizard Jul 22 '12 at 11:40
I use the exact same browser version (albeit on OS X) and have not observed this problem - but then, I'm hardly active on SO these days so I get only very few comments in the first place. Hmm, weird. – Pëkka Jul 22 '12 at 12:40
@Pekka: Are you seeing comment notifications for Meta? I'm not even getting those. Will try on other machines and browsers and see if there's any difference. – Jon Skeet Jul 22 '12 at 12:47
@Jon yup, seems to work just fine on both sites. – Pëkka Jul 22 '12 at 12:55
I've been getting comment notifications as usual, maybe it's specific to SO? – Ben Brocka Jul 22 '12 at 13:50
Weirdly enough, I seemed to have the same issue last couple of days but I am not experiencing the same problem today. It could be the browser (Switched from Chromium to Firefox today) or could be the latest build. – jokerdino Jul 22 '12 at 15:48
Editing around browser-ness.... – Jon Skeet Jul 22 '12 at 16:39
@JonSkeet maybe problems with Web sockets? Are you having same problems on train, or at work? – Benjol Jul 23 '12 at 7:57

You must log in to answer this question.

Browse other questions tagged .