What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

I get an error when I try to log into Data Explorer (SEDE), with OpenID, when already logged on with OpenID. The same occurs when I try to change my OpenID provider.

After looking at the account controller, it looks like it may be a null exception.

After a check has been made to see that the user is not anonymous, the OpenID variable is not null checked before determining whether its UserId property is the same as the CurrentUser Id.

share|improve this question
    
Oh wow, there's actually several things wrong there...I'll fix things up and assign blame appropriately. –  Tim Stone Jul 22 '12 at 11:00
    
Ah good, I'm not going mad! Glad I could help. –  Jules Jul 22 '12 at 11:15

1 Answer 1

As you thought, there was the potential for the code to attempt to access a property on a null reference, and that's been taken care of. Of course, even if it had gotten past that point, you'd have been sent to a 404 page on account of the return URL being incorrect (it was missing an "s").

There was also an additional problem with an edge case related to user merges that I fixed while I was in there.

The changes have to be pulled into the main repository and then deployed before they'll go live, but hopefully you'll see this fixed on the site soon. Thanks for the report! Now I can start Sunday off feeling like I did something productive by fixing three issues at once, and before getting coffee at that.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .