What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I opened Safari (6) today to access Stack Overflow. It crashes every time, a few seconds after accessing the site (any page). I tried it 5 or 6 times and after rebooting.

Has anyone else encountered this?

I ended up using Firefox instead.

Is this the right site for this question?

Crash:

Process:         WebProcess [370]
Path:            /System/Library/PrivateFrameworks/WebKit2.framework/WebProcess.app/Contents/MacOS/WebProcess
Identifier:      com.apple.WebProcess
Version:         8536 (8536.25)
Build Info:      WebKit2-7536025000000000~2
Code Type:       X86-64 (Native)
Parent Process:  ??? [368]
User ID:         501

Date/Time:       2012-07-30 16:01:27.295 +1000
OS Version:      Mac OS X 10.8 (12A269)
Report Version:  10

Interval Since Last Report:          50298 sec
Crashes Since Last Report:           9
Per-App Crashes Since Last Report:   7
Anonymous UUID:                      44EEFC82-3B94-4444-AB57-3ABB5325FAE0

Crashed Thread:  20  Dispatch queue: com.apple.root.default-priority

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: EXC_I386_GPFLT

Application Specific Information:
Bundle controller class:
BrowserBundleController

....

Thread 20 Crashed:: Dispatch queue: com.apple.root.default-priority
0   com.apple.CFNetwork             0x00007fff969e3c92 CoreSchedulingSet::copyWithUpdatesReleaseSelf(CoreSchedulingSet const*, CoreSchedulingSet const*) const + 104
1   com.apple.CFNetwork             0x00007fff969e3995 CoreSchedulingSet::copyWithAdditionReleaseSelf(__CFRunLoop*, __CFString const*) const + 71
2   com.apple.CFNetwork             0x00007fff96a46ac6 __executionContextSchedule_block_invoke_0 + 44
3   libdispatch.dylib               0x00007fff97585f3d _dispatch_call_block_and_release + 15
4   libdispatch.dylib               0x00007fff975820fa _dispatch_client_callout + 8
5   libdispatch.dylib               0x00007fff9758323e _dispatch_worker_thread2 + 304
6   libsystem_c.dylib               0x00007fff95733ceb _pthread_wqthread + 404
7   libsystem_c.dylib               0x00007fff9571e1b1 start_wqthread + 13

....
share|improve this question
    
I can't reproduce this on Mac OS X 10.7.4, Safari 6.0 (7536.25). Do you use any extensions to Safari? –  Martijn Pieters Jul 30 '12 at 5:55
    
Nope, Using Mountain Lion though. –  drekka Jul 30 '12 at 6:00
1  
This should be reported to Safari, whatever it is in SE code that makes it crash. –  Mat Jul 30 '12 at 6:29
    
Try to disable JavaScript and see if it still happens. If not, you have a lead. :) –  Shadow Wizard Jul 30 '12 at 6:34
2  
This blog post and its comments blame either the "Auto Proxy Discovery" and "Automatic Proxy Configuration" settings or a VPN connection, in case that's applicable to your situation. –  Tim Stone Jul 30 '12 at 6:44
1  
@Tim, you've found the answer: if I enable "Auto Proxy Discovery" in 10.8, then Safari 6 crashes when I reload Stack Overflow, and am logged in. It then always happens on SO, less frequent on SU, but not on a few other non-SE sites I tried. No problems if not logged in, or if not using that proxy setting. (I'm not using any proxy, but maybe OS X can find one at my ISP.) –  Arjan Jul 30 '12 at 7:43
    
@Tim and Arjan - I'm using a proxy and proxy pac file because I'm inside a corporate LAN. :-( Sounds like Apple has not done enough testing of proxies in Mountain Lion as Lion was quite happy with my settings. –  drekka Jul 30 '12 at 7:49
    
Still then, @drekka, you might not need that first "Auto Proxy Discovery" setting? (For me, not having any pac file at hand, only testing with that first option already made Safari crash.) –  Arjan Jul 30 '12 at 7:54
    
@Arjan Ah, sounds like it's probably related to WebSocket traffic with the proxy settings then. I don't know how to account for the difference between the SO and SU crash rates other than to say it's circumstantial, though –  Tim Stone Jul 30 '12 at 8:16
    
@Tim, I did see a "1 question with new activity" coming in on SU without any problem. Might still be a WebSockets issue (we've seen odd things with proxies earlier), but sometimes things are okay then. But ignoring that success: indeed websocketstest.com fails right away too. –  Arjan Jul 30 '12 at 8:40
    
@Arjan Yeah, I think it must be intermittent. SO's homepage doesn't use WebSockets if you aren't logged in, so I figured that's why you had no problem in that test case. Safari 6 introduces the new RFC-compliant WebSocket implementation, but I can't see any particular reason why that would cause the trouble (and presumably that was not involved in the applications mentioned in the blogs). –  Tim Stone Jul 30 '12 at 8:47
    
Well, no repro IE6 –  Won't Jul 30 '12 at 13:15
    
Just to be clear, I'm not using the Auto Proxy Discovery setting. I use Automatic Proxy Configuration and specify a pac file which Safari runs (it's javascript) to decided where to send each request. –  drekka Jul 31 '12 at 1:23
    
I don't use Auto Proxy Discovery or Automatic Proxy Configuration; I am on a corporate network where I have to specify the proxy settings manually. However, I am still seeing the crashing behavior described above. –  Jeremy Brooks Jan 4 '13 at 17:18
    
I faced this exact problem and my Safari is configured to use Auto Proxy Config, which I can't change due to insufficient permissions. However, instaling the AdBlock extension helped fix it. I was always doubting the Ads posted on SO. –  asgs Jun 26 '13 at 7:20
add comment

2 Answers 2

I'm afraid a browser crash is something we usually can't do anything about – simply for the reason that we shouldn't be able to cause it in the first place. If a website could cause browser crashes at will, that's a denial-of-service attack, even if (usually) the more harmless kind. Thus a crash means something is broken in the browser.

So your best bet is to report this to Apple and hope that they fix it quickly (at least quicker than Microsoft).

If it was easy for us to work around this issue, we would, but since we don't even know what is causing it (assuming there's even one particular thing you could point to; that's not at all certain for browser crashes), and apparently it isn't reproducible for everyone, I don't see anything we can do.

share|improve this answer
    
I myself file and follow the bug reports on Bugzilla (Mozilla), Connect (Microsoft) and Bugreport (Apple) and each of them has pending reports for years. Moreover, like Chrome, Firefox also dispatch the updates/bugfixes in next version of their browser but their new-version release life cycle is shorter than IE. As far as fanboyism/trolling is concerned, I am not a very big fan of these industry giants. At the same time I am giving you a neutral advise that mentioning IE-bug-report on Safari question would only create diversion for the readers. Peace! –  vulcan raven Jul 30 '12 at 7:44
    
(@balpha, just in case you're secretly investigating anyhow: see Tim Stone's comment, and note that for me it then only happens when logged in. And somehow it happens far less frequently on SU than on SO. That is: in my 15 minutes testing... I did see a "1 question with new activity" coming in on SU without any problem.) –  Arjan Jul 30 '12 at 7:47
    
I understand @Balpha, I'm trying to figure out if "It's just me!" or it's more wide spread. Currently it sounds like this is another issue with the new Safari and proxies. Why in particular with stackoverflow.com, I don't know yet. –  drekka Jul 30 '12 at 7:48
    
Oh and I have reported this via Apples bug reporter. –  drekka Jul 30 '12 at 7:49
    
(Ah, websocketstest.com fails right away too. Odd that the "1 question with new activity" came through without any problem then.) –  Arjan Jul 30 '12 at 8:43
add comment

To combine some results from comments, just for later reference:

The blog post Networking Crashes In Mountain Lion and its comments blame either the "Auto Proxy Discovery" and "Automatic Proxy Configuration" settings, or a VPN connection.

Some more investigation on 10.8, with only "Auto Proxy Discovery" enabled, without restarting Safari:

  • Safari 6 often crashes for Stack Overflow, but only when logged in. Super User crashes much less often, but also shows the issue. When not logged in, all is fine.

  • Going to websocketstest.com often (but not always) crashes Safari right away.

  • Going to the Echo Test on websocket.org seems less troublesome. Repeatedly connecting and disconnecting might not cause trouble, but it too will crash at some point.

So, it's probably related to proxy settings in combination with WebSockets.

share|improve this answer
    
Up=voted for the work it would have taken to do all of this. Also, I'm not using Auto Proxy Discovery. My setup uses Automatic Proxy Configuration and a custom pac file in the /Library/Managed\ Preferences directory. –  drekka Jul 31 '12 at 1:21
    
Aha. I have been unable to use Stackoverflow with Safari since I upgraded to Mountain Lion. Disabling "auto proxy discovery" fixed it. Thanks! –  Rex M Aug 25 '12 at 22:44
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .