Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 153 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I cleared all my browser data and visited http://stackoverflow.com and it logged me back in. How?

This happens on Chrome on OS X and Windows 7.

Surely the security concerns outweigh the benefits to the user. What if a family member or friend wants to use my machine? I wouldn't want them logged in as me.

Update

My mistake, I should have said data — all those checkboxes clicked/checked. I completely cleared everything, yet it still logs me back in.

Update 2

Here's a video to prove it: flickr.com/photos/therobyouknow/7749178118/in/photostream

share|improve this question
5  
You cleared just your history? That doesn't achieve a whole lot. – Bart Aug 9 '12 at 18:17
    
    
No actually, I cleared EVERYTHING, from the beginning of time... (sorry history was not the correct word for it) – therobyouknow Aug 9 '12 at 21:39
    
If you are sure you did, then from my understanding SO simply can't log you in automatically. And using Chrome myself I have certainly never seen this behavior. You are sure you did not click the image/link for your particular OpenID provider? – Bart Aug 9 '12 at 21:46
2  
There you go, proof enough: flickr.com/photos/therobyouknow/7749178118/in/photostream – therobyouknow Aug 9 '12 at 22:20
    
Clear all data. Close your browser. Not just the tab (All instances if you have more than one running). Start it again. Same problem? – Bart Aug 9 '12 at 22:24
1  
Yes, same problem, did a ps -ef | grep chrome in Terminal to ensure no Chrome instances running. – therobyouknow Aug 9 '12 at 22:27
up vote 10 down vote accepted

We use local storage to store important information about your login. I do see somebody else with a report of an issue with clearing local storage in the latest version of chrome 21: https://groups.google.com/a/chromium.org/forum/?fromgroups#!topic/chromium-html5/ize_mpI3e8w%5B1-25%5D

Confirmed - chrome v20 will clear local storage when you clear all browsing data - chrome v21.0.1180.75 will not.

share|improve this answer
    
+1 "chrome v21.0.1180.75 will not." is that a bug or a feature? To me that sounds like a bug in Chrome then. Security concern. "local storage" can be classified as "browsing data". – therobyouknow Aug 9 '12 at 22:55
3  
@therobyouknow You can manually clear the local storage by opening the developer tools, and pasting localStorage.clear(); in the console. Another option is to open the dev tools, open the Resources panel -> Local storage, and right-click on the entries to choose "Delete". – Rob W Aug 9 '12 at 23:06
    
Alternatively, in Settings->Advance Settings, click Content Settings (this button is next to Clear browsing data, then click All Cookies and site data... then a list is displayed - local storage item 'stackauth' corroborates with @Geoff Dalgas's point. Click 'remove all' to remove all of the list. Click Clear browsing data and that will do the trick - will solve my problem - this solution in the link that Geoff mentioned. I still think it's a bug because 'clear browsing data' includes 'clear cookies and other site and plug-in data and one would therefore expect this to clear everything. – therobyouknow Aug 9 '12 at 23:13
    
Accepting this answer with the comments as it explains why -- and also provides a link to solve the problem. – therobyouknow Aug 9 '12 at 23:14
    
+1 RobW for your alternative solution - this is a nice intro to the developer tools for me :) – therobyouknow Aug 9 '12 at 23:20

As Bart points out, browser history doesn't have anything to do with OpenID login that Stack Exchange uses. You'll need to clear your cookies and/or local storage data. In Chrome, that's one more checkbox you'll need to tick:

enter image description here

share|improve this answer
    
All of them were checked. I'll try it again now... see you in a few secs... – therobyouknow Aug 9 '12 at 21:37
    
...I'm back. Yes it auto-logged me in. Every single checkbox ticked. From. The. Beginning. Of. Time. ...too! – therobyouknow Aug 9 '12 at 21:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .