Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

EDIT: the badge got retired without me ever getting the chance to get it...

The problem

I have already read this post about this badge taking some time to be awarded and many other related.

BUT I have been waiting MONTHS. Cannot tell how many, but at least 4 for sure. And it was never awarded. Yes, I made sure that all the fields were expanded, both through the 'expand all' button and carefully expanding individual sections.

My browser

My computer ONLY uses Ubuntu with Google Chrome (the latest version downloaded from the official page and NOT from the Ubuntu Software Center). I never needed to install flash or anything, not sure if this is because of Google Chrome's pre installed one or Ubuntu's one, but everything except this badge works flawlessly on default. I guess it uses some kind of Javascript code (or other user-side script) to detect that all areas are expanded, and for some reason, it's not working for me.

Current versions:

  • Ubuntu 12.04 fully updated.

  • Firefox 19.0.

  • Google Chrome Version 21.0.1180.79 with (relevant extensions):

    • AdBlockPlus
    • Do Not Track Plus (only recently installed)
    • Google Dictionary

Where could my problem come from? Is there anything else I could do to help fixing this (apparently) bug?

share|improve this question

closed as too localized by ben is uǝq backwards, Doorknob, Rory, animuson, Emrakul Jun 9 '13 at 17:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Did you only try it once or have you tried expanding them all again? – animuson Aug 21 '12 at 21:52
I have tried several times in different sites of the stackexchange network, but mainly in stackoverflow. – Francisco Presencia Aug 21 '12 at 21:53
I don't care whether it's a bronze or a golden badge, something is broken, so I report it. – Francisco Presencia Aug 21 '12 at 22:48
FWIW I was just awarded the Analytical badge here on meta a few minutes ago after expanding all the sections of the FAQ. I am using Firefox 15 but I would be very surprised if the browser in use would have an impact on the issuance of badges, unless some plug-in was preventing some ajax call from registering the actions required for the badge. – Aaron Bertrand Aug 21 '12 at 23:12
Did you try again? I just did few hours ago and got the shiny badge now. Maybe when you tried few months ago it was broken, give it another try wait few hours and see. – Shadow Wizard Aug 22 '12 at 14:38
Confirmed, I tried again (without extensions) the same day and today I haven't got it yet. – Francisco Presencia Aug 26 '12 at 19:51
Yes, it doesn't work. – Kimi Jan 29 '13 at 16:09
Same here, badge not awarded if using OSX Chromium. Normally, that's the first thing I do in any new Stack I sign up, check the FAQ and get my Analytical. Used Firefox and it worked (here on Meta and in CodeReview) - awarded within minutes. – brasofilo Feb 24 '13 at 5:36

What I tried originally:

  • Expanding all sections using the expand all link at the bottom of the FAQ
  • Expanding all sections manually
  • Clicking on the shortcut links along the right hand side to jump down the page.

I didn't know how long the badge took to award at the time, but I gave it up, logged back in the next day and it was awarded - so it's gotta be at least one of these, if not more.

(I also actually read the FAQ, just in case the Stack Exchange Gods could tell if I was lying ;))

Browser: FireFox something-or-other, (it was a while ago - last year sometime)

  • Adblocker
  • Https Everywhere
  • Firebug


Just went through these steps again here on meta - Analytical awarded (although no global notification yet) - Firefox 14

share|improve this answer
I noticed the same thing - I've had other badge notifications in the meantime but I have yet to receive a notification for the Analytical badge. – Aaron Bertrand Aug 22 '12 at 0:28
@AaronBertrand The Analytical badge never gets a badge notification in the global inbox for veteran users. See here. – animuson Aug 22 '12 at 2:22
I see, so I will try without any plugin, and if it still doesn't work, I will try again when I get back to Uni from some windows machine. 'I also actually read the FAQ' – Francisco Presencia Aug 22 '12 at 8:34
I first clicked all the links on the side really quickly. 30 minutes later I clicked expand all and waited until the badge was awarded. Took about 15 minutes. Did this on MSO and C.SE. On main SO I only clicked the links on the side really quickly. Still awarded. Using Chrome 26 on Win 7. – fredsbend Apr 19 '13 at 18:25

It appears that Google Chrome (Version 24.0.1312.52) is causing issues.

I ended up here due to the same bug, where the badge was missing (despite being on SO for over a year).

I can confirm it worked flawlessly with FireFox, took around 15 minutes to get the badge, on both SO and Meta.

Active Extensions For Chrome:

  1. Edit This Cookie 1.2.1
  2. MeasureIt! 1.1.3
  3. REST Console 4.0.2
  4. REST Console Launcher 4.0.2
  5. Sight 1.10.2
  6. TooManyTabs for Chrome 1.9.6
  7. WhatFont 2.0.1
  8. YSlow 3.1.2

Out of all, MeasureIt! has given me a couple of issues in the past due to some of its faulty hooks.

P.S. Don't know if it matters but I'm using Incognito Mode almost exclusively.

share|improve this answer
I first clicked all the links on the side really quickly. 30 minutes later I clicked expand all and waited until the badge was awarded. Took about 15 minutes. Did this on MSO and C.SE. On main SO I only clicked the links on the side really quickly. Still awarded. Using Chrome 26 (not incognito) on Win 7. – fredsbend Apr 19 '13 at 18:26

Not the answer you're looking for? Browse other questions tagged .