What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

When reviewing suggested edits through the beta review system, I cannot (no longer) reject anything with a custom reason. Rejecting with any of the other options works as usual, but when I select "Custom" I get the following message:

You seem to be using JavaScript to avoid clicking a radio button, are you sure that is what you want to do?

share|improve this question
    
This must be an extension or plugin on your end. No repro on Chrome 21 beta. –  Purag Aug 25 '12 at 9:16
    
@Purmou I'm using Chrome 21.0.1180.82 on Mac OS 10.6.8, no plugins whatsoever - until today, it was working fine. –  Niko Aug 25 '12 at 9:18
    
Hm, interesting...is this still happening? Try to reject one again. –  Purag Aug 25 '12 at 9:19
    
Yupp, still the same, even after clearing the cache etc. –  Niko Aug 25 '12 at 9:24
3  
status-reproduced for me just now with Chrome 21.0.1180.81 (stable). I do have a few extensions but none that trigger on the /review-beta/suggested-edits pages. –  Gilles Aug 25 '12 at 16:15
1  
This happened to me personally when trying to enter a custom reason also. I cleared the error and tried a canned reason and it worked fine. –  animuson Aug 25 '12 at 20:07
1  
reproduced on Firefox 14.0.1 (ubuntu 12.04). Only plugin installed that might influence javascript is adblock. –  KillianDS Aug 25 '12 at 20:07
1  
Reproduced in Safari 6.0 for OS X Mountain Lion (build 8536.25) and Chrome 23.0.1245.0. –  user149432 Aug 26 '12 at 7:11
    
same on Super User i.imgur.com/jLY1M.png –  Sathya Aug 26 '12 at 7:37
    
Reproduced in Firefox 14.0.1 in safe mode. So it doesn't seem to be caused by an add-on... –  BoltClock's a Unicorn Aug 26 '12 at 7:51
    
Same issue using Chrome 21.0.1180.82 on OS X 10.8 –  John Gardeniers Aug 26 '12 at 11:39
    
Reproduced (on SuperUser) with IE9 and Firefox 13 on Windows 7. –  Indrek Aug 26 '12 at 12:38
    
Reproducible every time on OS X 10.8 and Safari 6.0 / Chrome 21.0.1180.82 - no extensions other than 1Password on either. –  bmike Aug 26 '12 at 13:12
2  
Ok everyone, I think we've confirmed that this is a global issue that affects a lot of different people. Now, why hasn't it been fixed yet!? –  animuson Aug 27 '12 at 6:05
1  
@animuson: Because it is a weekend and the SO team are still enjoying themselves doing something else. –  Jonathan Leffler Aug 27 '12 at 6:10
show 3 more comments

1 Answer

up vote 11 down vote accepted

This is fixed now. Sorry about that.

As part of a refactoring related to the new review UI, we started storing "rejection reason ids" with bytes instead of ints, and I failed to notice that we were representing "custom reason" with -1 on the client side (and bytes can't be negative).

share|improve this answer
1  
Well, at least it never gets boring for you! :-) –  Shadow Wizard Aug 27 '12 at 18:14
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .