What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

While meta is fine, the SO site is unusable to me : the main HTML file is received but all "dynamic" elements (StackExchange menu, arrows to vote) are missing. The "add comment" button is here but not working. So I can't do anything. I tested on my two computers (on the same LAN).

This started about 12 hours ago.

A big part of the problem seems to be related to the files served by http://cdn.sstatic.net.

I can't access this site but it seems It's not down for everyone:

http://www.downforeveryone.com/http://cdn.sstatic.net

I'm connecting from France. Is there a workaround?

EDIT:

traceroute to cdn.sstatic.net (108.161.188.213), 30 hops max, 60 byte packets
 1  neufbox (192.168.1.1)  0.882 ms  1.049 ms  1.534 ms
 2  1.152.76.86.rev.sfr.net (86.76.152.1)  44.569 ms  49.787 ms  56.711 ms
 3  233.187.17.93.rev.sfr.net (93.17.187.233)  172.675 ms * *
 4  te7-3.parigi31.par.seabone.net (213.144.183.78)  101.395 ms  106.895 ms  111.329 ms
 5  xe-0-0-2.cr1.cdg1.fr.nlayer.net (69.22.139.49)  116.822 ms  122.092 ms  126.746 ms
 6  * * *
 7  * * *

wget from a server I have at OVH works fine. Some people in France don't have the problem. It may be related to my ISP (SFR). Confirmations from France welcome.

EDIT AGAIN

Now it works. I'm a little disappointed to still not know whether this was a problem of my ISP.

share|improve this question

closed as too localized by Gnoupi, Jim, Toon Krijthe, Pops, Ben Brocka Aug 28 '12 at 0:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Most likely your ISP is blocking the host of the static files e.g. CSS and JavaScript files. –  Shadow Wizard Aug 27 '12 at 6:15
    
1  
I can't find a correct article, but I have seen some reports from a submarine cable being cut (For example, rockpapershotgun.com was not accessible from Sweden, Norway). Seeing as at my work, it seems to use a Sweden ISP (telia.net), it could be related. I don't know about others, though. –  Gnoupi Aug 27 '12 at 16:22
    
This is interesting. But wouldn't it be strange to have this problem during so much time while most access points were fine ? –  dystroy Aug 27 '12 at 16:28
    
I see requests for closing this question as too localized. What would be the correct site to discuss generalized (an ISP maybe) difficulties to access SO ? –  dystroy Aug 27 '12 at 16:30
1  
@dystroy This is the right place. There's little point in leaving the question open if the problem was a temporary failure of a server somewhere. –  Gilles Aug 27 '12 at 17:40
    
There is not much else to do. It's a rare occurence, it touched only a few people, for a short period of time. The only thing that "could" be done, would be to have a secondary cdn, but it's not really justified by such narrow situations. As for the question itself, like @Gilles said, it is not relevant anymore. It's the exact definition of "too localized". –  Gnoupi Aug 27 '12 at 19:45
    
Is that a "narrow situation" ? I was in the impression, looking at other similar questions, that this was a frequent problem. –  dystroy Aug 27 '12 at 19:48

2 Answers 2

up vote 5 down vote accepted

As a temporary workaround, I've downloaded on a personal server the most important files.

So anybody can make SO work by adding this line in the hosts file:

91.121.10.121 cdn.sstatic.net

Seems to work perfectly for me but if the files change, I won't track the new versions.

Don't hesitate to point any important file lacking: I'd do a wget to make it available.

Note that I have very little network/admin competences, so please tell me if something seems stupid. And of course don't refrain to answer this question as my answer isn't wholly satisfying.

share|improve this answer
    
It seems cdn is accessible again... I let the files but all users are advised to remove the entry from the hosts file. –  dystroy Aug 27 '12 at 15:23

Same issue from my work connection, in France, to connect to cdn.sstatic.net. The home connection (Free - Iliad) is finding it without issues.

U:\>tracert 108.161.188.213

Détermination de l'itinéraire vers cdn.sstatic.net [108.161.188.213]
avec un maximum de 30 sauts :

.......(skipped internal network bits).......

  9     7 ms     8 ms     9 ms  prs-b1-link.telia.net [213.248.70.77]
 10   109 ms   202 ms   203 ms  208.178.58.57
 11     *        *        *     Délai d'attente de la demande dépassé.
 12     *        *        *     Délai d'attente de la demande dépassé.
 13     *        *        *     Délai d'attente de la demande dépassé.
 14     *        *        *     Délai d'attente de la demande dépassé.

I don't see any common point with your own trace, so it's hard to know where is the broken link.

There is not really a solution to this problem. It is most likely only temporary. And even if it isn't, there is not really a solution, or something to do, besides circumventing (by using a proxy).


Edit: the connection to cdn.sstatic.net is back.

share|improve this answer
    
What's your ISP at work ? –  dystroy Aug 27 '12 at 8:48
    
@dystroy - you see as much as I know in the trace. –  Gnoupi Aug 27 '12 at 8:54
    
@dystroy Are you sure your companies don't have a proxy with some kind of 'smart' filter which may have suddenly decideed that cdn.static.net is 'bad'? I had to get the admins here to whitelist it and one point. –  Benjol Aug 28 '12 at 5:13
1  
@Benjol - He was on a home connection. For my case, you don't see the full trace, but it actually passed the internal network and the proxy and was already at the stage of the ISP and next. –  Gnoupi Aug 28 '12 at 5:46
    
@Gnoupi, ok ... –  Benjol Aug 28 '12 at 5:48

Not the answer you're looking for? Browse other questions tagged .