What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 129 Stack Exchange communities.

An extraneous line feed at the start of the page has stopped the feeds working properly. For example, I put http://tex.stackexchange.com/feeds into a Feed Validator and it shows:

Sorry
This feed does not validate.

line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

<?xml version="1.0" encoding="utf-8"?>
Source: http://tex.stackexchange.com/feeds

1.  
2. <?xml version="1.0" encoding="utf-8"?> 

This happened for a while last month until the line feed was removed..

share|improve this question

1 Answer 1

Yes, we broke it. Again. Hint for .NET/MVC folks - never leave whitespace lines in your _ViewStart.cshtml ;p

Deploying now.

share|improve this answer
    
You should even put a big warning comment in there just in case people forget! ;) –  Tim Stone Sep 14 '12 at 10:55
    
@Tim the funny thing is, that file is actually an old copy of our stackoverflow one, and I wrote that very comment. What I forgot to say in that comment is "or above". Some @using ... directives got added above that @{ ... } block, and a blank line ;( –  Marc Gravell Sep 14 '12 at 10:57
    
You need automated regression tests for this.. :-P –  Martijn Pieters Sep 14 '12 at 10:59
    
Yeah, I was poking fun, heheh (although I didn't know that you specifically had written it). Ahhh I see. Pesky return key. –  Tim Stone Sep 14 '12 at 11:04
    
Many thanks for fixing the problem so quickly. –  stevem Sep 14 '12 at 12:19
1  
@stevem we try to always be ready-and-willing to press the big "deploy" button. Fortune favors the brave. –  Marc Gravell Sep 14 '12 at 12:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .