Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I've been doing a lot of editing recently on StackOverflow, and I've noticed a bug in the markup scripts, in that occasionally when I click edit I get a somewhat broken page in which:

  • All the markup tools have disappeared
  • The edit preview box is blank
  • The tag box popup is just a plain text box (no special popups).

enter image description here

It only happens intermittently, and I've noticed this maybe 5 - 10 times in the last few days (maybe on 5% of edits).

This is only something I've noticed somewhat recently, though I can't be sure. I'm not running any user scripts or adblock or addons or anything when I see the error.

I realize this isn't much information to work with for debugging, though I'm not sure what other information I could usefully provide.

Using Firefox 15.0.1


New information

Every time I load a page, I get two errors in the FF console, though the errors appear whether the markup tools fail to load or not.

Error 1: no element found : Line 1 (no more information, sorry)

Error 2: The connection to ws://sockets.ny.stackexchange.com/ was interrupted while the page was loading : Line 11, and it points me to this line of the source:

StackExchange.inlineTagEditing.init();window.history.pushState(f,"new post","#"+f.id)}},x=function(){var b=Object.keys(p).length;f(b);return $(''+b+" question"+(1").click(function(){StackExchange.realtime.expandActiveQuestions()})};return{init:function(f){l=f;if("WebSocket"in window||"MozWebSocket"in window){if(o)try{a("closing WebSocket"),o.close()}catch(g){}o||(a("opening WebSocket"),o="WebSocket"in window?new WebSocket(l):new MozWebSocket(l),

share|improve this question
    
FF 15 doesn't show as officially being supported, but I don't know (and doubt) that it has anything to do with your problem. – Bart Sep 16 '12 at 18:22
    
When it happens, try checking the JavaScript console to see if there are any errors recorded. They would be extremely helpful in figuring out the problem, if they exist. – animuson Sep 16 '12 at 18:23
    
@animuson I was able to find some errors that I missed in the console, though they appear on every page load regardless of if I'm editing or not. I don't get any extra errors when the tools fail to load. – Tim Sep 16 '12 at 18:32

You must log in to answer this question.

Browse other questions tagged .