What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

When viewing PHP - Submit button does nothing in Opera Mobile 12.00, the

<form method='post' action='http://cogameservers.com/home/contact'>
Email: <input name='email' type='text' /><br />
Subject: <input name='subject' type='text' /><br />
Message:<br />
<textarea name='message' rows='15' cols='40'>
</textarea><br />
<input type='submit' />
</form>

section of the code not only renders the input areas, but also a working submit button. Strangely, I haven't found another question with the same effect.

Edit not by OP:

Here's what the page looks like in Opera 12 Mobile on ICS when using the desktop layout, the mobile interface and the mobile interface with Turbo disabled, respectively:

form and button rendered on full site

form and button rendered on mobile site

display is correct with Turbo disabled

share|improve this question

closed as too localized by animuson, kiamlaluno, Toon Krijthe, jonsca, Pops Sep 20 '12 at 14:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Lol, then it's more likely a browser bug rather than SO bug, I guess. –  nhahtdh Sep 19 '12 at 0:13
2  
Oh wow, repro'd on Opera Mobile 12.00 on an Honeycomb 3.2 tablet. This is a pretty serious bug in Opera –  Yi Jiang Sep 19 '12 at 1:24
    
Reproed on Opera Mobile 12 on an ICS phone. The fault is with Opera Turbo; when I disabled that feature, the problem went away. I grabbed some screenshots, which I could add after I'm done with work, not that they'll do anyone here any good. –  Pops Sep 19 '12 at 14:31
1  
I filed a bug with Opera and linked them to this page. I used the e-mail address mso147570@mailinator.com. There is no public tracker page, but I got the message "If you would like to update your report with more information, please send an email to: ANDMEX-12912 commercial at bugs.opera.com." –  Pops Sep 20 '12 at 19:23

1 Answer 1

up vote 2 down vote accepted

That's a browser bug that we here cannot do a single thing about. Everything Stack Exchange can do has been done. Those opening and closing angled brackets are already escaped/encoded into HTML entities. If the browser is actually rendering the HTML, that's the browser's problem.

<pre><code>&lt;?php
if (isset($_REQUEST['email']))

 {

$email = $_REQUEST['email'] ;
$subject = $_REQUEST['subject'] ;
$message = $_REQUEST['message'] ;
mail("necro@gophobia.com", $subject,
$message, "From:" . $email);
echo "Thank you for using our mail form";
}
else
 {
 echo "&lt;form method='post' action='http://cogameservers.com/home/contact'&gt;
Email: &lt;input name='email' type='text' /&gt;&lt;br /&gt;
Subject: &lt;input name='subject' type='text' /&gt;&lt;br /&gt;
Message:&lt;br /&gt;
&lt;textarea name='message' rows='15' cols='40'&gt;
&lt;/textarea&gt;&lt;br /&gt;
&lt;input type='submit' /&gt;
&lt;/form&gt;";
}
?&gt;
</code></pre>
share|improve this answer

Not the answer you're looking for? Browse other questions tagged .