What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

On the prefs-tab, when I input tags to be ignored, they appear on the page instantly and look fine, but the POST to actually save them to the server concatenates them sometimes.

I can reproduce the bug in Firefox and Google on Win XP, both when I type a tag in by hand and when I click on one of the autocomplete-suggestions.

Two screenshots of the problem, captured in firebug:

here the last two tags, installer and c are combined to installerc

screenshot of firebug: shows that POST sends different tags than shown on page

And this concatenated tag really get's stored and displayed when I load the page the next time

screenshot of garbled tags

share|improve this question
    
When you go back into your preferences, does it show them being concatenated? –  Jon Skeet Aug 16 '09 at 19:04
1  
How did you input them? –  Brad Gilbert Aug 16 '09 at 19:28

2 Answers 2

Wait a second -- are you reporting an actual BUG or just something you saw that "looked weird" in firebug? In other words, are the tags actually incorrect after being saved, or not?

Firebug has its own peculiarities; there was a time when running Firebug basically broke SO completely due to serious bugs in Firebug.

share|improve this answer
    
yes, it's a real bug –  bjelli Aug 16 '09 at 23:19
up vote 3 down vote accepted

I found the culprits: my "HUAWEI Mobile Connect" plus my mobile provider.

They do strange things to the javascript: strip out whitespace and insert external javascript into the html-page. they must be overdoing the thing with the whitespace.

This problem could be avoided if you used any other character than space to separate the tags.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .