What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I really need to ask this question on SO, but I'm not sure what's triggering the "code formatting" checker that is disabling my submission. I've cut sections out of the code that I think may be causing the issue, but to no avail.

Hey StackOverflow, for the past 4 days I've been trying to integrate Eclipse EE and Tomcat7 to no avail. I've tried the recommendations posted in a variety of other SO threads.

In terms of install configurations I've used the following methods:

  • apt-get install tomcat7
  • installation from .tar.gz source

I'm running on a clean install, and had been trying on the old install to get Eclipse EE to recognize a running or stopped Tomcat7 service (unsuccessful)

Environment variables

CATALINA_BASE: /usr/share/tomcat7

CATALINA_HOME: /usr/share/tomcat7

CATALINA_TMPDIR: /usr/share/tomcat7/temp

JRE_HOME: /usr/local/jdk1.7.0_07/jre

USING CLASSPATH: /usr/share/tomcat7/bin/bootstrap.jar:/usr/share/tomcat7/bin/tomcat-juli.jar

JAVA_HOME: /usr/lib/jvm/java The Tomcat7 service appears to be configured properly, upon navigating to localhost:8080, I'm greeted with "It works!", confirming a successful install. Any suggestions? I'm fresh out of ideas. Is Ubuntu 12.04 on my hardware simply not compatible with a package in Eclipse EE that allows it to sync up with Tomcat7?


Toggling the service on/off doesn't appear to make a discernible difference.

How can I link Tomcat7 to EclipseEE? Is it possible? Should I move to GlassFish or JBoss? I need to have this set up ASAP. I'm already losing too much time.

share|improve this question
    
Given that you have posted this now, I assume the issue was resolved? I also don't think this counts as a bug. –  Bart Sep 24 '12 at 14:08
4  
Have you tried using fixed formatting for the environment variable names? I bet that it sees capitals, underscores and colons and assumes it's some variety of programming language. –  Charles Sep 24 '12 at 16:45

1 Answer 1

Try using the <pre> tag around your code-like sections (CATALINA_BASE:.. etc)

share|improve this answer
2  
Downvoters, did you try using the <pre> tag before you downvoted? –  bobobobo Sep 24 '12 at 16:53
12  
The text clearly isn't code, and it is displayed properly with no html or markup, so the OP shouldn't need to do anything. –  Servy Sep 24 '12 at 17:18
    
@Servy This suggestion is intended to fix this instance of the problem for OP. If it does solve the problem, then vote it up and put a checkmark on it. –  bobobobo Sep 24 '12 at 21:22
8  
@The problem is that the message is indicating that there is unformatted code. There is no code to format. The fix is not to use code markup around text that isn't code (that would be harming the post, not fixing it), the fix is to change whatever automated process determines that there is unformatted code and "fix" it. –  Servy Sep 24 '12 at 23:54
    
It's probably hard to "fix" this, because the posted config file information does look like a bunch of case: labels. Is it worth "fixing" the problem? The <pre> tag isn't necessarily code, and there's no harm in formatting this data with it. –  bobobobo Sep 25 '12 at 1:02
    
I don't see how you could get case labels out of it, and wrapping this in <pre> tags would indeed cause harm; it would cause the markdown for the bold to be treated as astricks, rather than bolding the text. –  Servy Sep 25 '12 at 5:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .